This forum is shutting down! Please post new discussions at

Degradation output in Habitat Quality model


Running the Habitat Quality model i did not encounter any errors, however, the imageimageresult raster for degradation only has a thin line in the left side of the study area. The quality raster is ok. I ran the model using only a current land use raster (no future nor baseline) and did it twice to set parameter k to half the maximun value of the degradation output (even though the first result seemed odd).

I should clarify that the white pixels next to the color line in the degradation raster have values really close to cero (or ceros) and therefore classification does not change its color. The black/grayish pixeles have values like: -53416413110489158000000000000000000000.000000

So, is this normal? is it related to what is specified in the Invest User Manual: "locations near the edge of the area of interest may have inflated habitat quality scores, because threats outside the area of interested are not properly accounted for". And most importantly how do i fix it?

Thank you in advance




  • RichRich Administrator, NatCap Staff
    I would say that is not normal. Or at least a correct output of the model. Could you dropbox me your datastack to I'll see if I can recreate and fix the error on my end.
  • RichRich Administrator, NatCap Staff
    Hi @pamelapastors, I got your data. I saw your AOI was projected in lat/lng and I think the model requires all data are in the same projection. I reprojected your AOI to UTM17S which is what all your other rasters had and I was able to get it to run on my end. Can you try projecting your AOI and let me know if it doesn't work?
  • Hi @Rich, thank you so much for your response and help. I reprojected the access shapefile which was indeed in a different projection. Tried to run it, but the result is still wrong (same problem, degradation output shows a just a line). Then, i tried to run it without that layer, but the result still has the same problem. Any other thoughts? 

    Thanks again!

  • RichRich Administrator, NatCap Staff
    Hi Pamela, how about I take a look? Can you Dropbox your data to I'll see if I can figure out what's going on at my end.
  • I exported all the data again, setting all the 'NoData' values to 0, and that seems to have solved the problem. Nevertheless, results in the degradation output are below zero, would you take a look? Thanks again! 
    By the way i am using the latest version 3.4.2

    Here is the data:

  • edpedp Member
    Hi @pamelapastors and @Rich! sorry for the intrusion 1 year late. I have the same issue explained above. Every data have the same projection and the raster threats have same snap of lulc map. I would like to know if you were able to fix it in some way. (If you remeber in which way, 1 year later :) )

    Thank you!
  • RichRich Administrator, NatCap Staff
    Hi @edp, it's been a while, I don't remember what this issue might have been. But you said your values are below 0? Are they very negative, or very slightly numerically negative like -1e-32? I think there may be some numerical issues with our convolution algorithm that we can smooth out that I've got a todo list. Any chance you could send me your data to help with that either way? dropbox is
  • Hi @Rich, I'm sorry for the late reply but I tried to fix the problems. I checked the threat rasters and the baseline map, but in habitat degradation output everything looks the same as before,  Low value: -1.98062e+038, High value: 0.173445.
    I send you my data on dropbox. Thank you!
  • Hi @edp and @Rich

    I think that it was more of a visualization problem at last. I am not sure if it was the whole issue, but i remember i changed the minimum and maximum values (using qgis) in order to correctly visualize the output.

    Here i mentioned setting the No Data values to zero. That is definetly a bad idea. Don't do that, 

    After a year i think i have runned this model at least10 times. Here are some of the advises i can give you for the different erros i have encountered: 1) check the space available in your disk, try to have at least 10 gb (of course depends on the size of the files you are using), 2) check the projections (same projection, in meters), pixel size, raster extension and format, 3) make sure the names of the files are the ones required in the instructions of the model

    @Rich, lately i've been getting an odd result in the degradation output, where the minimun value of the raster is "-inf". I've been searching the forums and there have been some reports of this value BUT in other models. Would you mind taking a look? Here's the log. Thank you!

  • RichRich Administrator, NatCap Staff
    hi @pamelapastors, there isn't any good reason to be getting -inf values. I'd guess there's some nodata values that are leaking over because of a bug or something. I really hate to do this, because you might have sent it to me in the past, but could you dropbox me your datastack *again* and in the dropbox message link to this forum post? I get a lot of dropboxes and sometimes I'm never able to link them to the user on the forum. I apologize if you've already done this and I missed it before.
Sign In or Register to comment.