This forum is shutting down! Please post new discussions at

Scenario Generator - Error Messages No Matter What I do

Hi there,

I can't seem to get this module to work. I want to make a future scenario of a landscape I'm working in where they are new, large scale eucalyptus plantations in what otherwise is either a grassland or agriculture land use. It's a simple landscape with only 5 land covers -- should be easy!

I want to make a possible future landscape with a major expansion of eucalyptus plantations, and then do other modules.

I keep getting different errors -- nothing goes thru. I ran the sample data set and it worked but for the life me cannot get it to work with my transition file and raster.

Can you help me trouble shoot? 


  • jdouglassjdouglass Administrator, NatCap Staff
    Hi @phiferc,  of course, we're very happy to help troubleshoot.  In your output workspace, there should be a series of logfiles there, one for each of your model runs.  Could you post the latest one here so we can take a look at what happened?
  • Excellent. Here's the log file. The frustrating thing is I got this to work once, about 5 months ago, but not now. What am I doing wrong?

  • Hi there. I keep trying different things and different error messages. Here's the latest Is it the files? I have a clean TIF and based my table on the sample table. I have a total of three scenarios we want to model so I need to get this to work not once, but three times with different inputs. Thanks for any suggestions.
  • jdouglassjdouglass Administrator, NatCap Staff
    Well, it looks like there are two errors happening here, one in each of the logfiles.

    In the first one (ValueError: unsupported format character '\' (0x5c) at index 148), is it possible that there's a backslash (\) in one of your transition names?

    For the other one, I can't be positive because the error message and traceback wasn't written to the logfile, but based on the logfile, my guess is that the scenario generator crashed because your LULC does not have a nodata value defined. Is this possible?

    Hope these help!
  • Hi, 

    Yes, the nodata is blank. I have a 5 land-use map made from Landsat images. This includes the Mask, which we made to made to cover the landuses not of interest. What do you suggest?

    For the transition table, I am only selecting "specify transition" and "proximity" checkboxs. I based the table on the downloaded data excel file.

    The online guide is a bit confusing -- it does not do a good job of describing what the software needs and talking about the process of engaging stakeholders. 

    Ultimately, in this landscape there are new eucalyptus plantations, and we want to model a major expansion of them (like 300%) and also a scenario that matches the community values (which we surveyed for) and then show these maps to the communities as a focus group setting.

    Thank you,

  • Hi there,

    I fixed the raster file issue and finally fixed the other error. For the moment, I was able to run the module several times before it crashed due to memory issues. I'm really not sure what I fixed or how, frankly.

    I'm sure to have some more questions soon. Thanks InVEST team!

This discussion has been closed.