This forum is shutting down! Please post new discussions at

Issues with biophysical and sediment threshold tables (Sediment Retention model, Invest 3.0 64 bit)

edited July 2013 in Gulf Coast
Hey, NatCap folks!
I was trying to run for the first time the standalone version for the sediment model. Unfortunately I'm stucked at this issue: the biophysical table and the sediment threshold table are not recognized as good for the model, because the validation module says that the lucode and the ws_id fields are missing, respectively. But they are there! I have tried with csv, xslx and dbf versions of the same table, but the problem remains.

Do you guys have a clue?

Thank you!

João Guimarães
Post edited by kglowinski on


  • Thank you, Stacie! Your advice has solved the problem. When I opened the sample tables in Excel I turned unvoluntarily the comma separation to semicolons. When I've got back to comma, it ran perfectly!
    Thank you,
  • Hi there,

    I'm having a similar problem using the water nutrient model. I've tried to get the program to recognized the ws_id column and lucodes. I'm also having this problem with the watershed shape file - I get an error that it needs a column labled, ws_id but it's there.

    Eric Lonsdorf
  • DougDoug Administrator, NatCap Staff
    Hi Eric,

    Can you mention what version of InVEST you're running and what model. I'm assuming the Nutrient Retention Model.

    The watershed shapefile should have a field called 'ws_id' that has unique integer values of type integer. If you do and it's still bringing up an error, can you check to make sure the .dbf file is located in the same location as the .shp file.

    Also, feel free to attach the biophysical table for debugging purposes if you can, so we can take a look at why you might be getting an issue with the 'lucode' column.

    If all else fails, I'd be happy to take a look at your files too!

    - Doug
  • Hi InVEST users ,
    am trying to run SDR and NDR models  and( results)raster maps  are full of blank space(no data).
    anyone can help me to solve the problem?I I attached image of usle result


    420 x 167 - 17K
  • swolnyswolny Member, NatCap Staff
    Hi Rukundo -

    If I'm seeing correctly, it looks like a white checkerboard pattern on black, but there is no legend to tell what the colors mean - are the black areas where you have results, or where do you do not? I also assume that you're using some of the same inputs to both NDR and SDR (such as DEM and landcover.) Does this same pattern show up in all of your NDR and SDR output results?

    On the subject of the checkerboard pattern (assuming that this is incorrect - is it?), look closely at your DEM, and flow direction/flow accumulation rasters created from it. I have had this kind of pattern happen when reprojecting or resampling the DEM using a Nearest Neighbor sampling - Bilinear and Cubic don't produce the checkerboard, but a natural stream pattern.

    If you're missing large areas, also look at all of your spatial inputs - if any of them have a NoData somewhere, the result will be No Data. So make sure that all layers have complete coverage across your area of interest.

    ~ Stacie
Sign In or Register to comment.