Coastal Protection Python Extension Check

Hello,

I have installed InVEST 3.3.1 onto my computer and I have ArcGIS 10.3.1 installed as well. 

I have read over the User guide for the Coastal Erosion Protection model and understand it fairly well. However, I am having some difficulties with the python extensions. 

I have installed the Marine python extensions from this llink:  http://130.211.163.122/download.html. ;The most recent python extensions required for the InVEST model are for ArcGIS 10.2, but I have ArcGIS 10.3. 

The python extension check continues to state "This tool has no parameters." 

Is there a version compatibility issue here or something else going on?

Additionally, I have already ran the Coastal Vulnerability model with the sample data with no difficulties. 

Thanks,
Anthony 

Comments

  • jdouglassjdouglass Administrator, NatCap Staff
    Hi Anthony,  the python extension check doesn't have any parameters, so you should just be able to press 'ok' and have it execute.

    James
  • tHi Anthony. I too had a same problem. I too have ArcGIS 10.3. I also downloaded and installed the python extension form InVEST download page. But no success. Then i manually installed necessary extensions   required to run the coastal protection toolbox. I tried to install individual components. But still no success. Then i downloaded extension packs. I tried winpython, But still extensions were missing. So i downloaded python(x,y) package from here. https://python-xy.github.io/ .Download size is around 800mb. but it is worth it. Now i am able to work with the coastal protection toolbox. U try installing it.
  • Thank you for the comments. I will download python (x,y) to see it works. 
  • irondaffodill, did you uninstall the previusly installed extensions?
  • Nope. I didn't uninstall any previous extension.
  • Hi James and irondaffodill,

    I am having a problem with the coastal protection toolbox from InVEST 3.3.1.
    It seems that it comes from the Python extension.

    I got the error message when performing Extension check. Please see attached.

    Your help would be very appreciated!

    Thanks,
    Jaya
  • jdouglassjdouglass Administrator, NatCap Staff
    Hi @jkelvin, the error looks like it's coming from within arcpy, which is then trying to import the weakref module from your anaconda install.  There's so much proprietary stuff within the ArcGIS installs, I don't know how much we'll be able to help here!
Sign In or Register to comment.