This forum is shutting down! Please post new discussions at community.naturalcapitalproject.org

Habitat quality error - undefined value

Hello, 
I don't usually have problems with the Habitat quality model but can't get any of 5 scenarios to run. I get the error: "the following values were in the raster but not in the value_map set [o, 65535]". But none of the scenario LULC rasters have either of these values in their attribute tables. I can get the model to run to completion for our baseline LULC which has an identical set of rows & columns in its attribute table to all of the scenario LULCs but am stuck trying to run the other LULCs. 
Any suggestions?
Thanks,
Kris Johnson

Comments

  • jdouglassjdouglass Administrator, NatCap Staff
    Hi Kris, is it possible that the LULC rasters have some pixels with those values?  This error usually indicates that there were pixel values that the model could not reclassify because it couldn't find a value to reclassify to.

    If this isn't the case, could you share your input data with jdouglass@stanford.edu so I can take a look?

    Thanks!
  • jdouglassjdouglass Administrator, NatCap Staff
    We ended up solving this offline.

    It turned out that the LULC, an unsigned 16-bit integer raster, had a nodata value (65536) that the datatype could not possibly represent (it would only support values between 0 and 65535, inclusive).  The solution was to set the nodata value to 0, and then to set all values of 65535 to the new nodata value.
This discussion has been closed.