unable to format argument as string

JuanSeJuanSe Member
Hi guys!

I'm running the portfolio translator in RIOS and it shows me an error "unable to format argument as string". The error appears when "building raster attribute table for base_lulc.tif". I tried loading base_lulc.tif in ArcGIS and I'm unable to open the Attributes table, which seems to be the problem with the file. Am I doing anything wrong?

Cheers,

JuanSe

Comments

  • RichRich Administrator, NatCap Staff
    Hi JuanSe, it might be from some landuse names that don't convert well to ASCII characters.  Looking through your log I see a couple of strings that  have escape characters in them like this "Plantaci\xf3n forestal" and "Regeneraci\xf3n". I'm guessing GDAL won't accept those as string arguments to output raster tables.

    Also, just want to make sure you're using the latest version of RIOS 1.1.16? It's hard to keep track of anymore, but there's a chance we might have run across this before and fixed it. http://data.naturalcapitalproject.org/rios_releases/rios_1.1.16_x86_setup.exe

    If you are running 1.1.16 and still experiencing this could you try an alternative table w/ the non ASCII characters removed from the landuse descriptions? And if that doesn't work I'll ultimately need your data to shake out the issue directly.
  • JuanSeJuanSe Member
    Hi Rich,

    Yes, I'm using the latest version, but what you say makes a lot of sense. I always forget to avoid accent marks when building the biophysical tables. I'll try removing them and will let you know.

    Thanks so much!

    Best,

    JuanSe

  • JuanSeJuanSe Member
    Worked!! Thanks :)
  • RichRich Administrator, NatCap Staff
    Ahh, about time some forum posting did something good around here. :)
This discussion has been closed.