This forum is shutting down! Please post new discussions at community.naturalcapitalproject.org

Sediment Delivery Ratio Model

Hi all,

I'm using the SDR model to make predictions about the sediment delivery of a watershed. I added all the input data and run the model in InVEST 3.3.0 (Windows). I encouter an error that keeps returning and I believe my input data are correct. I also tried running it on another PC and I tried version 3.2.0, but that didn't work.

I get the following error: Error: exception found while running natcap.invest.sdr

In the attachments is my log file.

When I run the model with the base data it works properly.

Does anybody know what might be the issue here?

Thank you in advance,

Kind regards,

Hidde Kats
Tagged:

Comments

  • RichRich Administrator, NatCap Staff
    Hi Hidde, hard to tell exactly what's going on, but that line of code is encountered when the model aggregates the USLE over the watersheds using the "ws_id" field in the shapefiles.  Is there any chance that you're missing a "ws_id" or there's a "0" value for one of them, or something like that?

    If none of that makes sense, can you dropbox me your data stack to richsharp@stanford.edu and I can try to recreate the error on my end and see if I can fix it.
  • Dear Rich,

    Thank you a lot for you help. There was indeed an error inside my watershed shapefile. The ws_id was 0, when i changed it to 1 in ArcGIS it worked. However the odd thing is that inside the base data there is a watershed polygon with ws_id 0 and that one doesn't give errors.

    Many thanks to you!

    Hidde
This discussion has been closed.