This forum is shutting down! Please post new discussions at community.naturalcapitalproject.org

RIOS-Pre-Processing--Error mapping coefficients to landcover

Hi-

In running the RIOS Pre-processor using ArcGIS 10.3.1, I encountered the error below. I imagine it relates to the coefficients table. I am using that from Rios 1.1.3 as I could not find one included in 1.1.15 (what I am using now). Any advice would be most welcome. Many thanks!

Kind regards,

David
-----------error message------------
Error mapping coefficients to landcover:  ERROR 000358: Invalid expression
Failed to execute (MakeTableView).


Error processing Erosion Control objective:  ERROR 000358: Invalid expression
Failed to execute (MakeTableView).


Error running script
Failed script RIOS-Pre-Processing...

Traceback (most recent call last):
  File "E:\gis\work\tanzania\analyses\Agra\RIOS_Pre_Processing.py", line 1276, in <module>
    raise Exception
Exception

Failed to execute (RIOS-Pre-Processing).

 

Comments

  • Update: the RIOS Pre-processor with the same input ran fine in ArcGIS 10.2 so it seems, as noted in other posts,10.3 is the culprit. ArcGIS10.0 also did not work.

    Cheers,
    David
  • swolnyswolny Member, NatCap Staff
    Hi David, apologies for the slow reply. Adding support for Arc 10.3.x is on my list of things to do, and I'm sorry it's not done yet. Really, I'm more sorry that every single ArcGIS release breaks our geoprocessing scripts. Glad you have access to 10.2 and got it working.


    ~ Stacie
  • Thanks Stacie. I can imagine the challenge of matching RIOS to the new releases.

    Cheers,
    David
  • Hi Stacie,

    Well perhaps I spoke prematurely. I ran the Rios Investment Portfolio Advisor using my preprocessor output. It ran fine but the activity portfolios appeared blank despite having some hectare values in the IPA advisor report. Even if I boosted the investment values in a subsequent run, the hectare outputs were unchanged.

    I thought the trouble might be the DEM being pitted...indeed it had no data values. So I swapped that for a filled DEM and then re-ran the preprocessor. It failed on the error attached. Any thoughts?

    Thanks!

    David
  • swolnyswolny Member, NatCap Staff
    Hi David -

    How did the preprocessor outputs look from your first run (that you used in RIOS)? Was there anything obviously wrong with them, like missing data?

    If IPA doesn't seem to be choosing any activities, look at your LULC<->activity mapping and prefer/prevent layers - they could be so prohibitive that there's no area allowed to be chosen. One way to see this in the outputs is to look in the output folder activity_scores at the <activity>_prioritization.tif results - these contain scores only for the areas where RIOS thinks the activity should be allowed.

    Also, I've sometimes seen the outputs be fine but just not display correctly in Arc when you first put them in. In that case, changing the Symbology of the output layer helps.

    For the current error, I've seen read errors when you run out of disk space, or try to overwrite existing files (which should be allowed, but Arc sometimes refuses.) Assuming that you have enough disk space, try setting your
    Workspace to a new folder and see if that helps.

    Check these out and let me know what you find.

    ~ Stacie




  • Hi Stacie,

    Many thanks for your advice. I got it the IPA to run properly.  I think it was
    swapping the land use/lc layer for one with a uniform extent with the other
    inputs. Onward!

    Cheers, David

  • swolnyswolny Member, NatCap Staff
    This is really late, but for future information, one of our wonderful users has ported the RIOS pre-processor out of ArcGIS, so it can be run without this dependency. Here's the web page for this script: https://github.com/leonbaruah/rios_preprocessor

    Note that NatCap did not create this script, so it's not supported by us, and we have no expectation that Leon would provide significant support either, but I've tried it, it seems to work well, and I do recommend trying it.

    ~ Stacie

Sign In or Register to comment.