This forum is shutting down! Please post new discussions at community.naturalcapitalproject.org

Recreation model issue / scenarios

Hi, I've been working with the recreation model, and am unable to get the scenario (tool 2) to work.  I followed the advice in a previous thread (http://forums.naturalcapitalproject.org/index.php?p=/discussion/701/recreation-urlerror) but unfortunately, I'm still getting the same error message (..no modified predictors in this scenario...).  

The first tool worked well, and I was able to generate results.  (One thing I noticed is that that init.json doesn't seem to be updated; I would have expected to see a file saved around the time of the last model 1 run.  This might be the way it's supposed to work, but it looks like it's still the same file as when I ran the model with the sample data.)

Does anyone have any thoughts on how to resolve this, or what I might try next?  I've attached the log file.  Any advice is greatly appreciated!

Comments

  • DaveDave Member, Administrator, NatCap Staff
    Hi @MikeS,

    I think you are right that the problem may be related to that init.json file. Can you confirm that when you run the "Scenario" tool, you select the "init.json" file located in the results of your previous "Initial" model run?

    Also if that doesn't solve the problem, could you attach the log from your Initial run as well?

    Thanks
  • Hi Dave, thanks for the reply.

    I tried 'cheating' a bit.  My AOI is directly adjacent to the US/Canada border, so I edited the sample AOI and parks files to reflect my needs.  The base model ran great, and gave me what I expected.

    I edited the json file, but only change the grid size from 5000 to 1000, which matched the run above.

    The scenario did finish (progress!) but the AOI and grid size matched the input for the original sample data. I ran it again to make sure I hadn't specified some other version of the data, but had the same results.  Do you have any thoughts?  Might the model be looking for an init file in another location?  The log implies not, but those setting are coming from somewhere.  

    The only thing I can think of right now is to uninstall and reinstall the model, edit my data and then run the model with the defaults, and see if that helps.

    I've attached my (edited) json file (in the zipped file) and log file.  Thanks for any thoughts you might have.

    Best
    Mike   
  • DaveDave Member, Administrator, NatCap Staff
    @MikeS,

    I would recommend moving your workspace out of the sample data workspace. If you want to use the sample data (or even your edited versions of them) that is fine, but still change your "Workspace" to a new clean folder. Then, after the "Initial" model completes, unzip the results folder and find the init.json file there. That is the file you will supply to the "Scenario" model, and you should not edit it at all.

    If you're curious, you can compare that new init.json to the one you attached here and you'll see all the differences that are currently causing problems.

    Hope that works for you
  • I'm having the exact same problem! (Hi Mike!)

    I've attached my logs as well. In the scenario model, I added several campsite points. 
  • DaveDave Member, Administrator, NatCap Staff
    Hi @chris89,

    I believe you encountered a similar but different problem from Mike.

    I think you may need to change the filenames of your
    shapefiles to lowercase (only for your scenario run). For example change "HG_PEP" to "hg_pep". I know they were
    uppercase for your initial run, but I believe they were saved in our
    database as all lowercase, and that is the reason for all the messages
    like "WARNING Predictor HG_PEP is not in the grid."

    Thanks,
    Dave
  • I ran it with the updated files renamed to lower case, and got the message "hg_pep does not exist", same for hg_camp.

    I've now renamed both the initial run shapefiles and the scenario ones to be lower case, and am running initial tool again, then scenario on the new init file. I'll post back an update.
  • With hg_pep, still the same issue of existing. With hg_camp the scenario went through. 
  • DaveDave Member, Administrator, NatCap Staff
    @chris89, please upload your logfile again and I'll take a closer look. Sounds like we may be getting closer.
  • DaveDave Member, Administrator, NatCap Staff
    @chris89, thanks. Based on the log I'm not sure what is causing this error. If you can zip up and send me the data directory you used for that latest scenario run, I will try to reproduce the error and come up with a solution. You may email me the data at davefisher@stanford.edu

    Thanks again.
  • Hi Dave, I just wanted to post that I seem to have resolved my problems.

    One problem was the init file. For some silly reason, I thought this updated automatically, and didn't realize you had to copy it from the zipped results file.  The model kept referencing a file that was created when I ran the sample data.  I'll call this operator error.

    The other thing was that the shapefiles I created (using ArcGIS) were just not recognized by the model.  To work around this, I just copied the sample shapefiles and pasted my edited data into it.  My AOI is right next to the BC/WA border, so I was even able to keep it in the same projection.  That did the trick, and I was able to get run my scenarios successfully.  I probably should have used QGIS to create my scenario files, but in the end, the work-around was successful.

    Thanks for the advice.  Love the model; it's really a great resource.
  • DaveDave Member, Administrator, NatCap Staff
    Hi Mike, It's always great to hear about the successes! Thanks for posting.

    ArcGIS and QGIS sometimes create shapefiles with subtle differences from one another. In particular the syntax of the projection info can be different for some projections. Maybe that is what you were experiencing. Glad you found a solution that worked for you.

    If you're interested in sharing your results (with me or anyone) try out our Recreation model "Dashboard" for viewing and sharing results in a web browser. http://vulpes.sefs.uw.edu/ttapp/rec-dash.php

    If you load your results in the Dashboard and would like to share a link, my email is davefisher@stanford.edu (no pressure).

    Thanks,
    Dave


  • DaveDave Member, Administrator, NatCap Staff
    Hi Chris,

    It turns out the error "hg_pep does not exist" was caused by some extra
    files in your scenario data directory that had the suffix ":Zone.Identifier".
    So you had files such as "hg_pep.shp" and "hg_pep.shp:Zone.Identifier".
    I'm not sure where those came from, but deleting them solved the
    problem. I think our model was interpreting those extra files as an
    additional shapefile with the same name, which was a problem.
This discussion has been closed.