This forum is shutting down! Please post new discussions at community.naturalcapitalproject.org

RIOS v1.1.12 activity score files with faulty information

We are using RIOS v1.1.12 for a project in the Upper Cedar River in Iowa. Two test model runs completed without error, but the activity score and activity portfolio results do not make sense. 

Our model outputs can be downloaded here: https://tnc.box.com/s/qc2zkjuh28mq0btppg84sm6k46wkfdvu. For context, this RIOS run focused on identifying locations that would be best for the transition and directly related activity of fertilizer management for the single objective of nitrogen retention.

From looking at things, my sense is that the model is producing good results for the transition score outputs (i.e., the fertilizer management transition score file has values from 0.21 to 4.87). But there appears to be a problem in going from those transition scores to the activity scores (i.e., the activity score prioritization file has values of -3.42 e+38 to 3.42 e+38). And then the yearly activity portfolios that are generated don't make any sense. 

As far as I can tell, the preprocessing outputs are in good shape. Here's a link if you'd like to look at those: https://tnc.box.com/s/8cjxn1ifnwnn2h8p8gjv8rppuse1nn5i

Thanks for your help!
Josh

Comments

  • RichRich Administrator, NatCap Staff
    Hi Josh, if I'm reading your inputs correctly, it looks as though your inputs have only one activity 'fert_mngt' and use only Fertilizer management as the transition.  All the others transitions are zeroed out.  On the backend the transition rasters for the zero transitions are just nodata everywhere, in turn that makes the activity prioritization nodata since by default RIOS turns a pixel to nodata if there's any nodata in the stack at all.

    Anyway, I think we can do something reasonable, I'll post back here when I get some kind of patch working.
  • Thanks Rich - that's correct that for this run we are only looking at the fertilizer management transition and corresponding activity. 

    We did this same kind of one transition/activity run with an earlier RIOS version 1.0.0b10 and things worked fine at that time to generate results. So I'm not sure what has changed in the model between the 1.0.0b10 and 1.1.12 versions to impact things. 

    We are now updating everything for the analysis (final push to incorporate tweaks before writing up for publication) and trying to use the most recent RIOS version. 

    Thanks a lot for your help troubleshooting this!

    Josh
  • RichRich Administrator, NatCap Staff
    Hey Josh, I can't find the actual inputs to your RIOS run in the two links you sent.  I need the files that are located in directories like this:

    D:/GIS_Data/RIOS/RIOS_N_Ret_FertMgmt_20151009/IA_LULC_Activities_Fert_Mgmt_20150930.csv

    and 

    D:/GIS_Data/RIOS/RIOS_PreProcessingToolInputs_20140924/lulc_tilefd_soils_ia_02.tif

    That I'd need to recreate your issue.  Can you pass the pure RIOS inputs along?
  • Jim Platt has those on his computer. I believe he's out of the office today, so I'll have him compile and get you a download link tomorrow.

    Thanks,
    Josh
  • Hi Rich,

    Here is a link to a zip file with all of the inputs:


    Once you unzip it, you'll see folders that are labeled RIOS inputs and InVEST inputs. There are actually inputs needed for the RIOS runs in the InVEST inputs folder as well. 

    Jim did a new RIOS run this morning to make sure that the same error was reproduced, which it was on our end. And also to make sure that all of the input files were included in what we posted at the link above. The outputs from that run can be downloaded here, and the parameters file should have the correct relative pathnames for you to find the inputs from the RIOS inputs and InVEST inputs folders.


    Let me know if you have questions.

    Thanks,
    Josh



  • RichRich Administrator, NatCap Staff
    Hi Josh, I'm getting 404 error on that first link you sent.  Can you double check it?
  • RichRich Administrator, NatCap Staff
    Hi Josh, we were able to patch RIOS to handle your issue.  You can download the latest version here:  http://data.naturalcapitalproject.org/rios_releases/rios_1.1.13_x86_setup.exe

    Or if you just fancy the outputs from the inputs you passed along, you can grab them here: https://www.dropbox.com/s/5r408p5ggto2p35/jgoldstein_rios_1.1.13_outputs.zip?dl=0
  • Thanks Rich! The results look as expected now. Many thanks for turning this patch around so quickly.

    Josh
  • RichRich Administrator, NatCap Staff
    You're welcome!
This discussion has been closed.