Error 000229: Cannot open [input file]. Failed to execute (AddField)

jellisojelliso Member
edited September 2015 in Pre/Post-Processing
Hi all,

I'm receiving this error for the pre-processor in ArcGIS 10.2. It happened after resampling my LUC raster to a coarser resolution (2-m to 10-m) in order to match my DEM resolution. (I did not get this error before when using the 2-m LUC.) Datum and projection are correct. I can't seem to figure it out. I'd be glad to submit the LUC raster (it is small) if someone thinks it's a problem with my data...

Thanks!



From the log:

Processing Erosion Control objective...
Mapping coefficients to landcover...
Error mapping coefficients to landcover:  ERROR 000229: Cannot open P:\rios_preprocessing\rios_workspace4_10m_Er_5000\Intermediate\lulc_copy
Failed to execute (AddField).
Error processing Erosion Control objective:  ERROR 000229: Cannot open P:\rios_preprocessing\rios_workspace4_10m_Er_5000\Intermediate\lulc_copy
Failed to execute (AddField).
Error running script
Failed script RIOS-Pre-Processing...

Post edited by jelliso on

Comments

  • swolnyswolny Member, NatCap Staff
    Before you re-ran the pre-processor with the new LULC, did you delete the Intermediate folder first? If not, please try that, since Arc often has trouble overwriting previous files. It shouldn't be a problem with your LULC file itself.

    ~ Stacie


  • jellisojelliso Member
    edited September 2015
    Thanks Stacie,

    I've been deleting both the Intermediate and Output folders every time I make a run. Must be something else...


    Post edited by jelliso on
  • It is strange because the same 2-m LULC actually works fine with the InVEST SDR model. 

    To clarify, in the RIOS pre-processor, the 2-m LULC creates the error (see above) while the 10-m LULC (prior to resampling) works fine.  However, I must use the 10-m LULC to match my other data. 


  • Would someone be willing to take a look at my 10-m LULC? 
  • swolnyswolny Member, NatCap Staff
    Sorry about dropping the ball here, I'm away on work travel with limited connectivity. It's very strange to me that just changing the LULC would lead to this message, it really shouldn't be the cause. Usually I've seen the 'cannot open' error when my disk is full, or I have the file open in ArcGIS, or there are permission problems, or Arc just decides to have file-locking problems (which deleting the Intermediate folder and/or restarting Arc generally helps.)

    Have you tried things like saving to a new Workspace folder? What happens if you use the 2m LULC and set the Workspace to P:\rios_preprocessing\rios_workspace4_10m_Er_5000\ (as with the 10m LULC above)? I'm not sure how well I can download data right now, but if other things don't work, perhaps you can upload your whole data stack, that way I could try running it and see what happens.

    ~ Stacie
  • No worries, Stacie! 

    ...However, despite the workspace folder tricks, the same error returns.  Luckily, I believe my input rasters are relatively small, and can be found HERE.


  • swolnyswolny Member, NatCap Staff
    I just tried running your inputs and got the same error. It happened because the LULC has type float, and it needs to be an integer, when I turned it into an Int it fixed that problem. Is it possible that your 2m LULC is type int?

    But then I got errors on the R-erosiv, K and depth-to-bedrock layers, because they needed to have Calculate Statistics run on them. Once I did this, the preprocessor completed without error.

    Looks like I need to add more checking within the preprocessing script for things like that. Let me know if anything else comes up...

    ~ Stacie
  • I am so glad to hear this! Thanks so much for helping me get over this road bump! 
Sign In or Register to comment.