RIOS error with large number of activities

Greetings,

We are working with a large watershed for which there happens to be an extensive amount of data on land management activities.  We have 101 activities which we would like to include in the RIOS model. In addition we have 21 activity preference shape files to go along with these activities. In trying to run the model with these activities and preferences, RIOS produced 4 prioritization rasters, but crashed and the program closed.  I have attached a screenshot of the error window, and the log file. Subsequent to this crash, I deleted the 21 activity preference shape files and ran the model again. This time, RIOS ran for about an hour and a half, but then ended with an error.  I am also attaching the log from the run without the activity preference shape files.

Would you be able to suggest a way we could figure out what
is going on with this model setup?

Thank-you,

Kathy Freeman

Tagged:

Comments

  • jdouglassjdouglass Administrator, NatCap Staff
    Hi @kfreeman,

    Thanks for including your log and the screenshot of the crash!  Crashes like this are uncommon and usually point to a serious issue with one of the underlying libraries we use.  Unfortunately, the particular error is of the  "unknown cause" variety, which will make it hard to diagnose.

    I see you're running RIOS 1.1.3 ... would it be possible to upgrade to RIOS 1.1.8 and try running it again?
  • Hello,

    Thanks for letting me know about the new version.  I did run both scenarios with v1.1.8.  Using the 21 activity preference files, it
    seemed to give the same error, log file attached.  Using no activity preference files it gave
    the error of “too many open files”, log file attached.  Would this error be less likely if I ran it
    on a machine with more memory?

    Kathy

  • This is an addition to my last comment.  Back in June, when we had a lesser number of activities, we did run into a memory error in RIOS.  It was suggested (by Richard Sharp) to try RIOS version 1.1.3 instead of version 1.1.1.  At the time, this resolved the memory error we were getting.  Not sure if this is related to what is happening now.

    Kathy

  • RichRich Administrator, NatCap Staff
    Hi All, sorry for the error on this.  We're aware of that issue, but I'm the only RIOS maintainer and wish for more hours in a day (ask anyone).  This is now officialy in my TODO priority queue, and I'll post back here when I can get to it.  Hopefully soon!
  • Hello Rich,

    Thank-you for putting this in your priority queue.  If I can assist you in any way let me know.

    Kathy
  • RichRich Administrator, NatCap Staff
    Hi Kathy, we patched that issue today that addressed the `too many files open` issue you were experiencing.  You can download it directly here: http://data.naturalcapitalproject.org/rios_releases/rios_1.1.9_x86_setup.exe
This discussion has been closed.