This forum is shutting down! Please post new discussions at community.naturalcapitalproject.org

Pre-processing tool seems to crash

evdreepevdreep Member
Hi,
I've tried running the pre-processing toolbox various times on data from a watershed in Peru, but every time all it seems to do is get stuck (unless it's supposed to run for hours, but I'm not sure). Unfortunately, it does not seem to write a log, but I took two screen shots. Any ideas how I could go about solving this problem? 
Thank you very much in advance!

1366 x 768 - 265K
1366 x 768 - 201K

Comments

  • swolnyswolny Member, NatCap Staff
    Hi @evdreep -

    It probably shouldn't run for hours, unless your data is very fine-resolution. I'm a little confused about what's happening here in your screenshots. Is it getting stuck for hours on checking projections? That would be unusual, since that should be a very quick process, but I'd check to make sure that everything is in the exact same projected coordinate system. Then does it continue eventually to give you the error on Flow Direction? Or are these separate runs, or with different datasets, having different problems?

    Since you're getting an error with Flow Direction, I'd take a look at the DEM. If it is a huge file, it just might be too big for Arc to handle. Or you might have sinks in the DEM that are causing Arc to get stuck in a circular flow path (that has happened to me before, not often though.) First, try running the DEM through Arc's Flow Direction tool and see if it hangs there too. If so, try filling sinks a time or two and see if that helps - it might just be that your DEM has problems that need to be addressed.

    Which version of RIOS are you running, and which version of ArcGIS? I haven't gotten around to supporting Arc 10.3 yet, so that could cause problems.

    Finally (and importantly): I've had to update the pre-processor, as things in RIOS 1.x have changed that are incompatible with how the older pre-processor worked. This means that the pre-processor that is shipped with RIOS 1.x does not work properly. Attached is a new toolbox and script that you can try, and if it ends up running for you I'd appreciate knowing, and we'll get the new version out very soon. This version does not attempt to address any problems that you might have with projections or flow direction, so those may still happen.

    ~ Stacie

  • Hi Stacie,

    Late, but better late then never... Thank you for your help. You'll be happy to know I got the Pre-processing tool to work. 

    Thanks for your help! 
    Elisabeth
  • swolnyswolny Member, NatCap Staff
    I'm glad to hear it, Elisabeth. If you did any troubleshooting that might be useful for other people to help solve the problem, please post it here.

    ~ Stacie
Sign In or Register to comment.