Error Scenario Generator

Hi everyone,

I am having trouble running the Scenario Generator tool. It gives me this error "TypeError: unsupported operand type(s) for /: 'unicode' and 'float'".

I have attached the error notie and the log file. Anyone know what is going on?

Thanks in advance,

Kimberley

Comments

  • DougDoug Administrator, NatCap Staff
    Hi @kimfungloy

    Can you check the landcover transition table, specifically the "Percent Change" column. I think the values from this column are causing the issue. I believe these values should be a float.
  • Hi Doug,

    I will definitely check those values. I will let you know how it works out. 

    Thanks so much :)
  • Hi Doug,

    I have looked at the Percent Change column in the transition.csv file. I do not know how to change these values. I tried different formats and I then get another error message. i have also seen in the log that it says that for certain covers "no change indicated" I have seen that these covers correspond with the covers which I have given a negative value or no change value (0).

    I tried attaching the .csv file but it does not want to upload
  • DougDoug Administrator, NatCap Staff
    I suspect that the warning message is connected to the Percent Change column... Unfortunately our forums refuse to take .CSV files for some reason. Do you think you could save the transition table as a text or xls file and upload it? 

    Or email it to ddenu@stanford.edu. 

    Thanks!
  • DougDoug Administrator, NatCap Staff
    Actually, if you want to zip up your workspace with inputs, I could try to get it working on my end. Feel free to dropbox or zip and email me at ddenu@stanford.edu
  • DougDoug Administrator, NatCap Staff
    Hi,

    As I mentions in a private email here is the link to the issues for the tool:


    Unfortunately I was not able to debug and provide a workaround given the state of the tool. Hopefully an update comes sometime in the near future and we can make this tool more robust.

    Thanks for your patience
  • Hello, 

    I have encountered the same problem. So is there a solution or a way to work around it? How do we make it work?

    Thanks!


  • Hi,

    For the unicode error, I received the following help which allowed me to run the model:
    jdouglass Administrator, NatCap Staff 
    Hi @kimfungloy,

    The error UnicodeEncodeError: 'ascii' codec can't encode character u'\xeb' in position 726: ordinal not in range(128) is because there's a non-ascii character used when generating the html table, probably in the "Name" column of the transition table.  My guess from the u'\xeb' ordinal is that it's an e with umlaut (http://www.codetable.net/hex/eb) in one of the rows.  The scenario generator doesn't handle non-ASCII characters very well at the moment, so would it be possible to replace the the ë with an e or some other character and see if that works?

    Thanks!
    James
Sign In or Register to comment.