Nutrient retention model

Output.tif file does not contain results for the whole watershed. only few areas are dispalyed like patches or more like subwatersheds.i tried several versions of Invest.2.5.5,3.1.1,3.1.3. all of them gave same results.could somebody tell me why this is happening?


  • RichRich Administrator, NatCap Staff
    Maybe it's a bug on our end.  Can you dropbox me your datastack to to see if I can recreate the issue?
  • RichRich Administrator, NatCap Staff
    Looks like your DEM has a hydrological of pits in it.  Here's a screenshot I snapped with the green pixels being the pits.  You're probably seeing missing data because the model routes along hydrological flow paths, and those stop if they hit a pit.  Can you try filling your pits first, then re-running the model?

  • indikaindika Member
    HI rich. it worked. thanks a lot. but still some areas are missing.Herewith i attached the filled DEM. Could you please check it again?
  • RichRich Administrator, NatCap Staff
    It looks okay on my end.  Note that the model masks the export and retention to the watershed inputs you pass in, so that might be the visual issue you're experiencing?  Here's what the n_retention looks like on my end overlaid with the watershed polygons:

Sign In or Register to comment.