This forum is shutting down! Please post new discussions at community.naturalcapitalproject.org

ValueError: invalid literal for int () with base 10: ''. open water'

I assume the issue is with my LULC raster because if the "open water" 

I think this is a float issue when it expects an Integer. My raster is a signed integer 32 bit. Is that the problem.  

Any suggestions>? 
Tagged:

Comments

  • RichRich Administrator, NatCap Staff
    Is there any chance the value of the landcover entry in your biophysical table is not an integer somehow?  Like the letter "O" or a random space in there?  If not, can you dropbox us your data stack so we can take a look?
  • Thanks Rich! The table had no spaces, I ask excel to treat the numbers and number, but when I reopen the table (csv) it tells me the format type is "general" I had suspected that the issue was with the raster (tif). I also tried to run only one objective and got the same error. I looked into my Pre processing inputs and they also look fine. 

    Thansk in advance for your help,

    Simcha
  • sleventalslevental Member
    edited February 2015
    When I add the CSV to ArcMap (just to check the type) It tells me its all double. Though, I also manage to get it to say it was a short integer and I still get the same error. 
    Any thoughts?

    Post edited by slevental on
  • Here is a screenshot of my error caused by general_lulc_coefficients.csv 
    659 x 303 - 22K
  • Just uninstalled and re installed RIOS and the problem persists... I am not sure what do do next.
  • Problem solved! Will investigate the issue and reposr back! 

  • Is this "ValueError: could not convert string to float: Woody Wetlands None" error related? 

    Now my model is finally running. I am wondering if this error is related to my previous issue. Or if anyone has any idea how to solve it.

    Thanks so much in advance for your assistance! 

    Simcha 
  • OK. I think this issue is related to the raster. lucode in my raster is float 
    My next attempt is going to be to run a sa.lookup on lucode

    Traceback (most recent call last):

    File "invest_natcap\iui\executor.pyc", line 553, in runModel

    File "C:\Program Files\RIOS 1.0.0b12 x86\rios_data\.\rios\rios.py", line 28, in execute

    File "C:\Program Files\RIOS 1.0.0b12 x86\rios_data\.\rios\rios.py", line 202, in execute_30

    File "C:\Program Files\RIOS 1.0.0b12 x86\rios_data\.\rios\rios.py", line 1223, in _normalize_rasters

    File "C:\Program Files\RIOS 1.0.0b12 x86\rios_data\.\rios\rios.py", line 1344, in _map_raster_to_table

    ValueError: could not convert string to float: Woody Wetlands

    None


    02/10/2015 15:33:35 root ERROR Exiting due to failures

  • Lookup did not work. Not sure what string it attempts to convert and if its not a number it cantbe a float. 
  • jdouglassjdouglass Administrator, NatCap Staff
    Hi @slevental,  sorry about the delay!  Usually this sort of error happens when there's a column that's out of place.  The exception is happening when RIOS tries to build a factor raster from your general_lulc_coefficients table and your lulc.  Could you maybe attach your coefficients table to this thread so we can take a look?

    Thanks!
    James
Sign In or Register to comment.