This forum is shutting down! Please post new discussions at community.naturalcapitalproject.org

Help with Rios Pre processing Error normalizing raster

Any suggestion on how to approach this?
 
Error normalizing raster I:\Research\Shares\h2oeco\slevental\OutputsRIOS\Output\Hydro_layers\slope:  ERROR 999999: Error executing function.
Failed to open raster dataset
Failed to execute (SingleOutputMapAlgebra).


Tagged:

Comments

  • This error was caused by running the analysis on a network drive that might have had some space restrictions. But still had plenty of room. Essentially, I am learning that to run everything locally :( 

    I also had an issue with locks not being erased and therefore blocking the model from fully running. This might have been caused by having the same data loaded in multipel MXDs. 
  • RichRich Administrator, NatCap Staff
    Thanks for the info.  I'm not an arc expert, but I've seen that lockfile thing before and I'd guess you are right.  Let us know if you have any other issues.
  • swolnyswolny Member, NatCap Staff
    Sorry for not responding sooner. Starting with Arc 10, there have been a lot of locking issues that we've been unable to work around. Indeed, I have found that sometimes using a Workspace on a different physical disk sometimes helps with errors like this. I'm glad that you were able to work around it, and thanks for sharing how.

    ~ Stacie

  • sleventalslevental Member
    edited February 2015
    Glad I was able to help! 

    Post edited by slevental on
  • Dear all,

    I'm running the Rios pre-processing tool for "Erosion Control" in ArcGIS 10.0. 
    I have the following error. Could I please have your assistance?

    Thank you

    Executing: RIOS-Pre-Processing true # # # # "C:\Users\Utente\Documents\RIOS ASMARA\RIOS_INPUT3" CC_LULC_TOKER LU_CLASS_TABLE "C:\Users\Utente\Documents\RIOS ASMARA\RIOS_INPUT2.gdb\GENERAL_LULC" C_DEM_TOKER C_EROSIVITY_RI30_TOKER C_ERODIBILITY_K_TOKER C_SOILDEPT_TOKER # # # # 2000 90 # TEST3
    Start Time: Wed Mar 18 00:10:46 2015
    Running script RIOS-Pre-Processing...

    Validating arguments...

    Erosion Control selected, checking required inputs:
    DEM
    Erosivity
    Erodibility
    Soil depth
    Land use/land cover
    Land use/land cover general class table
    RIOS general coefficient table
    Threshold flow accumulation
    Riparian buffer distance

    Checking input raster projections...


    Processing Erosion Control objective...

    Mapping coefficients to landcover...

    Creating downslope retention index...

    Defining flow direction channels...

    Created Erosion downslope retention index: C:\Users\Utente\Documents\RIOS ASMARA\RIOS_INPUT3\Output\erosion_downslope_retention_index_TEST3.tif

    Creating upslope source...

    Error processing Erosion Control objective:  Failed to execute. Parameters are not valid.
    ERROR 000865: Input raster or constant value 1: 1.0 does not exist.
    Failed to execute (Minus).


    Error running script
    <type 'exceptions.Exception'>: 
    Failed to execute (RIOS-Pre-Processing).
    Failed at Wed Mar 18 00:11:11 2015 (Elapsed Time: 25,00 seconds)
  • swolnyswolny Member, NatCap Staff
    Hi Blal, nice to see that you're starting work with RIOS.

    First, which version of ArcGIS are you using? It might be a compatibility problem.

    Another possibility is that ArcGIS might not like the space in your input path at "RIOS ASMARA" - try changing that to RIOS_ASMARA (with an underscore instead of a space) and see if that helps.

    The script is failing in a strange place that it really shouldn't, so let's check these two things first before troubleshooting further.

    ~ Stacie




  • swolnyswolny Member, NatCap Staff
    Oops, sorry, you said that you were running in ArcGIS 10.0 - I think that should work. So try the second suggestion and let me know how that goes.

    I also see that some of your data is in a geodatabase - can you try copying the data so they live in a folder, not a database, and let me know if that changes anything?

    ~ Stacie
  • Hi Stacie,

    Thank you for your prompt reply.
    I have tried both of your suggestions, but still not working. 

    B.
  • swolnyswolny Member, NatCap Staff
    Thanks for sending your inputs, Blal. I am currently swamped getting ready for this year's training at Stanford, but will look at them as soon as I can.

    ~ Stacie
  • Hi Stacie,

    Thank you for your extremely helpful input. In fact, the main problem was with how Windows and Arc were interpreting periods vs commas in numerical values. As you suggested I set my windows language to English and the Pre-processing worked well. I hope this information will be useful to other users.

    However, there is another issue with the results I am getting, which are different from those you sent me. In particular, the upslope source has the min and max values equal to 0 (in your case it was 0 and 59547.8), the riparian index has min 0 max 0.87 (yours was 0.2 and 0.87). What could be the problem?

    I think there is a similar question in the forum, so I-ll also look there.

    Thank you,

    Blal
     
     

  • swolnyswolny Member, NatCap Staff
    Great, glad that fixed the error, and thanks for posting the information here.

    As for the different results.It's certainly wrong if it gave all 0 values for upslope source. Can you send me your Intermediate folder so I can look through those files and see where things went wrong?

    As for the other values, it is possible that we used different threshold flow accumulation or buffer width values, which would affect the results. I just used test values of 1000 for the threshold flow acc and 30 for buffer width, but your actual values might be different.

    Also, a reminder that when you run RIOS, your input activity and general coefficient tables will need to be in .csv format instead of Excel.

    ~ Stacie
  • swolnyswolny Member, NatCap Staff
    Thanks for sending the Intermediate folder. For the riparian index, the 0 values (that do not appear in my results) are all along a straight vertical line off to the right side of the study area. It's not obvious from the Intermediate files why this is happening, but my guess is that there's some sort of Extent or Snapping set in your Arc environment that's causing a slight shift in the rasters, leaving this gap along the edge. You could see if there are any environment settings that might be causing the problem, or simply work around it by setting the 0 values to NoData. This doesn't seem to happen in the upslope/downslope results.

    For upslope source being all zero values, this is happening because your erodibility raster (only that one) is not normalizing correctly, producing a result (Intermediate/erod_idx) that is all NoData. Since this isn't happening on my computer, it's hard to tell what's going wrong on yours. The only thing that happens in the normalization is that ERODIBILITY_K_TOKER.tif is divided by the maximum value in the raster (0.33300000429153.) But something in here is going wrong. Can you look at the properties for this raster in Arc and see if anything looks wrong with the Maximum value? Or if there's anything different with erodibility than erosivity/soil depth/etc? What happens if you do the normalization by hand using Raster Calculator?

    Since you're having a few things go weird, I'm wondering if it would be useful to start a new ArcGIS document, only add the layers (in the same UTM coordinate system that you sent me) that you're putting into the pre-processor, and see if anything improves.

    ~ Stacie

This discussion has been closed.