Flow accumulation calculating in the sediment retention model inVEST 3.0 standalone

Jorge_MSJorge_MS Member
edited July 2013 in Terrestrial Models
Hello colleagues,
I am trying to run the inVEST 3.0 stand alone sediment retention model for the first time. The model ran with no problems in the processing, but the results for flow accumulation, ls, v_stream (intermediary outputs) seem to be wrong. For some reason, that I do not know, only a fraction of my interest area showed results, the rest of the map has No data. The others intermediary outputs (flow direction, export and retention rates, slope and cp) apparently showed no problems, they have data all over the modeled area. The final outputs maps and tables were hindered by this problem in the flow accumulation calculation. Someone can help me? Thanks.
Post edited by Jorge_MS on

Comments

  • RichRich Administrator, NatCap Staff
    Hi Jorge, I suspect this is a known bug that is occuring on the 3.0 tools regarding routing on some DEMs. I don't know the nature of it yet, but it is a high priority for me. Fundamentally I am recreating the functionality in TauDEM from David Tarboton at Utah State University: http://hydrology.uwrl.usu.edu/taudem/taudem5.0/index.html

    Expect this issue to be fixed in the release next month. I'm deeply sorry for the issue. In the meanwhile you could try the existing ArcGIS version of the model, but that sometimes has its own issues, as well as having significantly longer running times.
  • Thanks for elucidate this problem to me, Rich.
    I will try the ArcGIS version, and wait for the next release.
    Thanks again. Best regards.
  • Hello again,
    Following your previous advice, I was running the InVEST 2.5.5 ArcGIS version and the error message below occurred. I googled this and found that perhaps the cause may be the reversing of comma/periods. I tried to set English as pattern language but the error persists. Could you give me some help?
    Thanks.

    Error pre-processing sub-watershed 1: Failed to execute. Parameters are not valid.
    ERROR 000865: Input raster or constant value 2: 0.0 does not exist.
    Failed to execute (Times).

    It's possible that the sub-watershed is too large.
    Skipping to next sub-watershed...
    Error processing sub-watershed id 1: Failed to execute. Parameters are not valid.
    ERROR 000865: Input raster or constant value 2: 0.0 does not exist.
    Failed to execute (Times).

    Error running script
    :
    Failed to execute (1_Soil_Loss).
  • Hi Jorge,
    We faced a similar problem with language settings years ago with ArcGIS. We had to change the language settings in Windows (not in Arc). I take it you did the same thing?
  • Hello Nirmal,
    I changed the Windows default language to English and in the first attempt to run, the model fail, but when I tried again, it ran without problems. It seems that the language settings were the problem. Thanks for helping.
Sign In or Register to comment.