Nutrient Retention model

MarkusAMeyerMarkusAMeyer Member
edited July 2013 in Terrestrial Models
I have the following error below, but I cannot explain the explanatory link anymore. Can somebody tell me the solution?

Best, Markus

Messages sorted by: [ date ] [ thread ] [ subject ] [ author ]

Re: Error combining sub-watershed outputs???

http://invest.ecoinformatics.org/discuss/tier-1-water-purification/73628864/995879536

Dear all, I am receiving the same error as described above: Error
combining sub-watershed outputs. My six sub-watersheds have unique
ID's from 1-6. The manual conversion to a raster file was successful,
all six watersheds were properly converted and displayed. I am using
ArcGIS 10.1 and InVEST 2.4.4. Does someone know any solution for this?
This is part of the protocol: Processing hydrological rasters...
Creating hydrology layers... DEM has no sinks or areas of internal
drainage. Calculating runoff index... Calculating adjusted loading
values... Created adjusted load outputs:
C:\InVEST_2_4_4\WP_Nutrient_Retention\Output\adjl_sm
C:\InVEST_2_4_4\WP_Nutrient_Retention\Output\adjl_mn Calculating
fraction of nutrient removed... Calculating nutrient removal...
Processing sub-watershed id 1... Pre-processing input/output grids...
Validating input raster resolution... ......... Processing nutrient
removal output rasters... Processing sub-watershed id 6...
Pre-processing input/output grids... Validating input raster
resolution... Resampling removal efficiency raster... Calculating
nutrient removal per cell... Processing nutrient removal output
rasters... Combining watershed outputs... Error combining
sub-watershed outputs: ERROR 999999: Error executing function. Failed
to copy raster dataset Failed to execute (Mosaic). Error running
script Traceback (most recent call last): File
"C:\InVEST_2_4_4\python\WP_2_Nutrient_Retention.py", line 1365, in
raise Exception Exception Failed to execute
(Nutrient_Retention). Failed at Mon Feb 18 11:31:09 2013 (Elapsed
Time: 1 minutes 22 seconds)

Comments

  • swolnyswolny Member, NatCap Staff
    Hi Markus -

    If you can, the first thing I'd recommend is running the latest version of InVEST, and using the standalone Nutrient Retention model that's found in the Windows Start Menu. This version will run much faster, and without the ArcGIS dependency, has one less layer of problems to debug.

    That said, I've seen this error mainly in the following circumstances:

    - You're out of disk space, which you can determine easily.

    - Arc has decided to have locking problems, which are hard to fix. First, try closing your ArcGIS session, delete the C:\InVEST_2_4_4\WP_Nutrient_Retention\Intermediate folder, reopen your ArcGIS .mxd and try again. Or, try changing your workspace to another folder (or even better, another disk if you have one) and re-run the tool with this new workspace.

    ~ Stacie
  • Thank you for your quick reply.

    I will try the standalone version.
    Markus
  • Dear InVEST team,

    I have an error in the watershed output dbf file. The field shows for several subwatersheds in the column
    mn_run_ind,N,24,15
    -1
    -1
    -1
    -1
    -1

    The similar error occurs with P.
    This error occured after I have changed the land use raster dataset
    I would be glad if you helped me.
    Markus
  • This error seems to be connected to the fact that there are gaps (no data areas) in the preceding tiff files (upstream water yield, runoff_index). How can I avoid these gaps?

    Running the procedure with the watershed instead of the subwatershed layer produces the same error.

    I am using the slower inVEST version for calculating in case that might make a difference.
  • RichRich Administrator, NatCap Staff
    It could be that your dem is not hydrolocially consistent, but if not the newest version of invest 2.5.6 has an improved routing algorithm associated with it. Could you try thatvversion?
  • Thanks for your help. But originally, I did not have this error with the same DEM. The error occurs similarly with the versions 2.5.4-2.5.6. Once I used the water yield model and afterwards the 2.5.4 nutirent retention model and then it worked properly. But unfortunately not always. Do you have another idea?

    Best, Markus
  • Version 2.5.6. Produces the runoff index dataset correctly, no gaps as in 2.5.4, but does not calculate the mean runoff index, i.e. there is no data in the mean runoff dataset. What can I do about? Does it depend on the size of the dataset?
    Best, Markus
  • RichRich Administrator, NatCap Staff
    Hi Markus, looks like I'll have to look at your data directly. Can you email it/dropbox it/or give me an FTP site to it? My email richsharp@stanford.edu
  • Dear InVEST team,

    I get the following error when running the Nutrient Retention tool:

    Executing: Nutrient_Retention C:\InVEST_2_5_6_x86\WP_Nutrient_Retention C:\Users\sgiberti\inVest\InVESTinputs\North\dem30_fill_m C:\InVEST_2_5_6_x86\WP_Nutrient_Retention\Output\Pixel\wyield_ma C:\Users\sgiberti\inVest\InVESTinputs\North\landuse C:\Users\sgiberti\inVest\InVESTinputs\North\HUC8s.shp C:\Users\sgiberti\inVest\InVESTinputs\North\HUC10s.shp C:\Users\sgiberti\inVest\InVESTinputs\North\CTriver_north.dbf C:\InVEST_2_5_6_x86\Base_Data\Freshwater\Water_Tables.mdb\Water_Purification_Threshold true # 1000 MINOF NN
    Start Time: Fri Oct 04 12:03:59 2013
    Running script Nutrient_Retention...

    Validating arguments...

    Checking input raster projections...

    Processing hydrological rasters...
    DEM has no sinks or areas of internal drainage.

    Calculating runoff index...

    Error calculating runoff index: ERROR 010092: Invalid output extent.
    Failed to execute (FlowAccumulation).


    Error running script
    :
    Failed to execute (Nutrient_Retention).
    Failed at Fri Oct 04 12:04:03 2013 (Elapsed Time: 4.00 seconds)

    I tried different suffixes, and running it with an empty map, but it didn't help.

    Could you please help me solving the problem?

    Thanks,
    Silvana
  • RichRich Administrator, NatCap Staff
    Hi Silvana, are all your inputs in the same projection? Looks like there might be a spatial overlap issue. Also, could you try our standalone model, it's available in the windows start menu. Also Markus, I am still working on your data issue, more soon.
Sign In or Register to comment.