This forum is shutting down! Please post new discussions at community.naturalcapitalproject.org

Recreation Initialization Error

mvemve Member
edited December 2014 in Marine Models
Hi NatCap Team,

My name is Marius and I'm thinking about using InVEST for my Master's Thesis. I am just getting started on the tool and wanted to run the Recreation Initialization Model, sort of as a test run, because it doesn't require too much input.

After feeding in the shapefile and selecting some Land Use / Land Coverage Data sets, I hit the run button and this was the result:

IOError: Error on server: WKT 'GEOGCS["GCS_WGS_1984"|DATUM["D_WGS_1984"|SPHEROID["WGS_1984"|6378137||0|298||257223563]]|PRIMEM["Greenwich"|0||0]|UNIT["Degree"|0||0174532925199433]]' unknown: Traceback (most recent call last):
None

12/11/2014 14:14:17 root ERROR Exiting due to failures


I couldn't find this problem here in the forum, so I was wondering if anyone could help me with my problem?!

Thank you very much in advance!

Cheers,
Marius

PS: Logfile attached

Comments

  • DaveDave Member, Administrator, NatCap Staff
    Hi Marius,

    Thanks for posting. This error is saying that the coordinate system of your Area of Interest shapefile is not one of the supported systems. The Rec model requires the AOI to be in a projected coordinate system that uses meters as the linear unit. Please see the user's guide for a little more detail.

    A UTM projection is a reliable choice, but you'll need to know the correct UTM zone to choose. Here's a UTM zone map to help.

    Cheers,
    Dave
  • Hi!
    My name is Cristina. I am trying to running the recreation model but i have a similar error, but I am using (or i think so) the UTM systems.
    This is my error: 

    IOError: Error on server: WKT 'PROJCS["ED50_UTM_zone_30N"|GEOGCS["GCS_European_1950"|DATUM["D_European_1950"|SPHEROID["International_1924"|6378388|297]]|PRIMEM["Greenwich"|0]|UNIT["Degree"|0||017453292519943295]]|PROJECTION["Transverse_Mercator"]|PARAMETER["latitude_of_origin"|0]|PARAMETER["central_meridian"|-3]|PARAMETER["scale_factor"|0||9996]|PARAMETER["false_easting"|500000]|PARAMETER["false_northing"|0]|UNIT["Meter"|1]]' unknown: Traceback (most recent call last):

    None


    I have reprojected the shape but is not work.

    Thanks in advance!


  • DaveDave Member, Administrator, NatCap Staff
    Hi Cristina,

    Sorry for the delay here, I've been travelling. I have added your coordinate system to our database, so please try again. If it still doesn't work you might try projecting to this system http://spatialreference.org/ref/epsg/32630/

    It is the same UTM zone 30N, but uses a more conventional datum.

    Thanks,
    Dave
  • Thanks Dave, this worked.
    but another question, Is it possible that the recreation model provides negative values? If not, which may be due to this? 
    Thanks
    Cristina
  • DaveDave Member, Administrator, NatCap Staff
    Hi Cristina, can you be more specific about which output contains negative values? Are they In the grid.shp attributes (which columns?) In the aoi_params.csv?

    Thanks,
    Dave
Sign In or Register to comment.