Blue Carbon Model (BCM) - Sample Data Output Invalid

mlacayomlacayo Member
edited November 2014 in Marine Models
Hi @Behnaz,

I have moved your question to a new thread.

You wrote:
I am running the the BCM with the default data. I can open the LULC raster file in the "Input" folder in ArcMap but I am unable to open the LULC raster maps that are produced in the "Output" folder. I see this error when I want to add the raster maps in the output folder to ArcMap: "Invalid raster dataset. Failed to create raster layer"

Could you please advise on the reason?
I have just run the model using the sample data with InVEST 3.0.1 and I was able to open all the output rasters in ArcMap 10.2.1. Can you tell me what version of InVEST and ArcMap you are using? What operating system are you using? Are you on a personal computer (where you have full permissions) or on a work and/or university computer (where you have limited permissions)? If you can, please include a log file from the output folder with your reply.

Thank you,
Martin

Comments

  • Hi and thanks Martin.
    The version of ArcGIS is 9.3 (I am able to open the tif files in the "input" folder)
    The version of Invest is 3.0.1(x86)
    I am using my personal laptop that its operating system is 32-bit.
    I have attached a copy of the log file into the message.
    Many thanks
    Behnaz
  • gverutesgverutes Moderator, NatCap Staff
    Hi Martin and software team,
    I noticed this same issue at a training we had last week with Arc 9.3 users. The issue that Behnaz mentions is not a problem with the blue carbon model. Instead, it is the new way that InVEST generates .tif outputs. These tifs (from all models) can not be open in ArcGIS v9.3.
    -Gregg
  • Hi Behnaz and Gregg,

    Thank you for bringing this issue to my attention. I suspect the problem is related to LZW TIFF compression, but I am not sure. I searched online and did not find any information information regarding this. I would suggest installing any ArcGIS service packs that are available, which is in general a good thing to do, but this might not solve your problem. One alternative would be to download a development version of InVEST in which LZW compression has been disabled and see if that makes a difference.

    Here is information about installing service packs for ArcGIS 9.3, but according to this ESRI product life cycle document ArcGIS 9.3 reached the end of support in December, 2013 meaning that ESRI no longer supports, so if possible it would probably be best to upgrade or give QGIS a try.

    This tool should help you determine which service packs you already have installed:

    http://downloads2.esri.com/Support/downloads/other_/PatchFinder.exe

    Here are links to the service packs I could find:

    ArcGIS Desktop 9.3.1 Service Pack 1

    ArcGIS Desktop 9.3.1 Service Pack 2

    Here are links to both InVEST 3.0.0, which did not have LZW compression enabled, as well as a development version of InVEST that also does not have LZW compression enabled.

    InVEST 3.0.0
    InVEST development version 10d6a34fbd59

    Please let me know what you decided and if that makes a difference.

    Cheers,
    Martin
  • Many thanks Martin for the time you spent on my question. Just saw the message.
    Do I need to replace InVEST 3.0.1 with the 3.0.0?
    Thanks
    Behnaz
  • Hi Behnaz,

    I think the best and easiest option is to replace InVEST 3.0.1 with the the development version. Which models are you using in addition to Blue Carbon?

    -Martin
  • Thanks Martin. Probably the coastal protection model.
  • Great, please let me know if your problems with Blue Carbon clear up.
  • ok. Thanks Martin.
  • Hi Martin.
    I've just run the BCM from the InVEST development version. But I received an error when running the tier 2 (blue carbon calculator).
    I attached the log file and the error.
    Thanks for your kind support
    Behnaz
  • Hi Behnaz,

    Have I understood correctly that you did not have this problem with InVEST 3.0.1, but are having the problem with the development version?

    Thank you,
    Martin
  • RichRich Administrator, NatCap Staff
    Yep and just to contribute here, we've disabled GeoTIFF compression in future versions of InVEST because of this exactly problem. For anyone who got here because of that issue, try out this version of InVEST: http://ncp-dev.stanford.edu/~dataportal/nightly-build/InVEST_dev594_3_0_1 [68f4b157a496]_x86_Setup.exe
  • Hi Martin and Rich;
    Just saw the messages and thanks a lot for the feedback.

    Martin, I've had the problem with both InVEST 3.0.1 and the development version.

    Rich, I've installed the InVEST from the link you provided, but again I got error running the BCM (tier 2).

    The log file is attached.

    Thanks for your kind assistance
    Behnaz
Sign In or Register to comment.