This forum is shutting down! Please post new discussions at community.naturalcapitalproject.org

Coastal protection profile generator

emilianaemiliana Member
edited October 2014 in Marine Models
Hello,
we try to run coastal protection models in Arcgis 10.1. The profile generator module doesn't run properly with the Belize and Vancouver example datasets and we get always the same error:

Executing: ProfileGenerator22 F:\Coastal_protection tent_bez LandPoint_Belize_Sand LandPolygon_Belize "(1) Yes" dem_bathy_bz_ProjectRaster1 # 250 25 # 5 "C:\InVEST_dev445_3_0_1 [31f81f0a4133]_x86\CoastalProtection\Input\ErosionProtection_Belize_Sand.xls" WaveWatchIII 50 "(1) Yes"
Start time: Tue Oct 28 16:50:14 2014
Run the script ProfileGenerator22...

Checking and preparing inputs...

Error checking and preparing inputs.
Executing: CreateFeatureclass F:\Coastal_protection\scratch Fetch_AOI.shp POLYGON # DISABLED DISABLED "PROJCS['WGS_1984_UTM_Zone_16N',GEOGCS['GCS_WGS_1984',DATUM['D_WGS_1984',SPHEROID['WGS_1984',6378137.0,298.257223563]],PRIMEM['Greenwich',0.0],UNIT['Degree',0.0174532925199433]],PROJECTION['Transverse_Mercator'],PARAMETER['False_Easting',500000.0],PARAMETER['False_Northing',0.0],PARAMETER['Central_Meridian',-87.0],PARAMETER['Scale_Factor',0.9996],PARAMETER['Latitude_Of_Origin',0.0],UNIT['Meter',1.0]];-5120900 -9998100 450445547,391054;-100000 10000;-100000 10000;0,001;0,001;0,001;IsHighPrecision" # 0 0 0
Start time: Tue Oct 28 16:50:16 2014
Succeded at: Tue Oct 28 16:50:16 2014 ( 0,00 seconds)
Completed script ProfileGenerator22...
Failed execution (ProfileGenerator22).
Failed at: Tue Oct 28 16:50:16 2014 (2,00 seconds)

any suggestion?!

Comments

  • Hello,

    I don't know the answer to this question. I would imagine that you might be missing some Arc functionalities, but not sure. I'll ask our GIS expert.

    In the meantime, just to make sure, you installed all the Python Marine Extensions that are required by the tool? http://www.naturalcapitalproject.org/download.html
  • gverutesgverutes Moderator, NatCap Staff
    Emiliana,
    This looks like a problem with your system and not the model. Please check that all the Python extensions are properly installed and that you don't have multiple versions of Python installed on your PC. Also, make sure that the Spatial Analyst extension for ArcGIS is activated. If the PG still doesn't work, I would suggest trying another computer. Sometimes multiple installs of ArcGIS and Python on one PC will result in conflicts when the model tries to call the python extensions.
Sign In or Register to comment.