This forum is shutting down! Please post new discussions at community.naturalcapitalproject.org

Freshwater, Sediment, Soil Loss- Error Calculating USLE

ghwest11ghwest11 Member
edited July 2013 in Terrestrial Models
I am having trouble getting the Soil Loss script to run properly in the Freshwater Models of InVEST 2.5.4. When I use an Access Database for my Biophysical Models, I get an error:

Error calculating USLE: ERROR 010429: Error in GRID IO: RMPValidate: Invalid Remap data are entered near record 12 and 13 .. Unable to initialize reclass table
ERROR 010067: Error in executing grid expression.
Failed to execute (ReclassByTable).

My Biophysical Models numbers are in sequential order when opened inside Access, but not inside ArcGIS. Wondering if this might be the issue, I tried the Biophysical Models as a .dbf instead. When I run the model with the .dbf, the tool runs indefinitely and does not return an error or execute the model.

Does anybody know why the ReclassbyTable will not execute? What other issues could exist with my Biophysical Models table? This layer seems to be the issue, though I could also see the Landuse layer being the issue. Any ideas?

Thanks, Grant
Post edited by Rich on

Comments

  • There was some sort of corruption in my Landuse layer. I downloaded a new national landuse dataset, clipped it to my study area, reclassified it appropriately, and the tool executed that part of the code wonderfully.
  • RichRich Administrator, NatCap Staff
    Glad you figured it out Grant! Sorry for the delay.
This discussion has been closed.