This forum is shutting down! Please post new discussions at community.naturalcapitalproject.org

Carbon model Error 'carbon_combined'

yshennanyshennan Member
edited June 2014 in Terrestrial Models
Hi, I am trying to run the carbon sequestration model. My input raster is a TIF file, I have also tried an OVR grid file but both have given me this error:

Initializing...
06/18/2014 14:59:50 root DEBUG PATH: ['C:\\InVEST_3_0_1_x86\\invest-3-x86\\.']
06/18/2014 14:59:50 root DEBUG Loading carbon_combined from PATH
Arguments:
V 21.7
c 2.0
carbon_pools_uri C:/Users/yara/Documents/Dissertation/Analysis/carbon_pools.csv
carbon_price_units Carbon (C)
do_biophysical True
do_uncertainty False
do_valuation True
lulc_cur_uri C:/Diss_data/Manu/LULC_cd2_t.tif
lulc_cur_year 2010
lulc_fut_uri
lulc_fut_year
r 6
suffix carbon2
workspace_dir C:\InVEST_3_0_1_x86\Carbon


06/18/2014 14:59:50 root INFO Logging will be saved to carbon_combined-log-2014-06-18--14_59_50.txt
06/18/2014 14:59:50 root DEBUG Loaded the model from invest_natcap.carbon.carbon_combined
06/18/2014 14:59:50 root INFO Executing the loaded model
06/18/2014 14:59:50 root INFO Running InVEST version "3.0.1"
06/18/2014 14:59:50 root INFO Python architecture: ('32bit', 'WindowsPE')
06/18/2014 14:59:50 root INFO Disk space remaining for workspace: 589.73 GB
06/18/2014 14:59:51 root INFO Pointing temporary directory at the workspace at C:\InVEST_3_0_1_x86\Carbon
06/18/2014 14:59:51 root INFO Updating os.environ["TMP"]=C:\Users\yara\AppData\Local\Temp to C:\InVEST_3_0_1_x86\Carbon
06/18/2014 14:59:51 root INFO Updating os.environ["TEMP"]=C:\Users\yara\AppData\Local\Temp to C:\InVEST_3_0_1_x86\Carbon
06/18/2014 14:59:51 root INFO Setting os.environ["TMPDIR"]=C:\InVEST_3_0_1_x86\Carbon
06/18/2014 14:59:51 root INFO Starting carbon_combined
06/18/2014 14:59:51 carbon_combined INFO Executing biophysical model.
06/18/2014 14:59:51 carbon_biophysical DEBUG Found a process pool: None
06/18/2014 14:59:51 root ERROR ---------------------------------------------------
06/18/2014 14:59:51 root ERROR ---------------------- ERROR ----------------------
06/18/2014 14:59:51 root ERROR ---------------------------------------------------
06/18/2014 14:59:51 root ERROR Error: exception found while running carbon_combined
06/18/2014 14:59:51 root DEBUG
06/18/2014 14:59:51 root DEBUG Build details
06/18/2014 14:59:51 root DEBUG System
06/18/2014 14:59:51 root DEBUG OS : Windows-post2008Server-6.2.9200
06/18/2014 14:59:51 root DEBUG Processor architecture: AMD64
06/18/2014 14:59:51 root DEBUG FS encoding : mbcs
06/18/2014 14:59:51 root DEBUG
06/18/2014 14:59:51 root DEBUG Python
06/18/2014 14:59:51 root DEBUG Version : 2.7.3
06/18/2014 14:59:51 root DEBUG Build : ('default', 'Apr 10 2012 23:31:26')
06/18/2014 14:59:51 root DEBUG Compiler : MSC v.1500 32 bit (Intel)
06/18/2014 14:59:51 root DEBUG Implementation : CPython
06/18/2014 14:59:51 root DEBUG Architecture : 32bit
06/18/2014 14:59:51 root DEBUG Linkage format : WindowsPE
06/18/2014 14:59:51 root DEBUG
06/18/2014 14:59:51 root DEBUG Packages
06/18/2014 14:59:51 root DEBUG Cython : 0.19.2
06/18/2014 14:59:51 root DEBUG Numpy : 1.7.0
06/18/2014 14:59:51 root DEBUG Scipy : 0.11.0
06/18/2014 14:59:51 root DEBUG OSGEO : 1.10.1
06/18/2014 14:59:51 root DEBUG Shapely : 1.2.18
06/18/2014 14:59:51 root DEBUG InVEST : 3.0.1
06/18/2014 14:59:51 root DEBUG
06/18/2014 14:59:51 root DEBUG
06/18/2014 14:59:51 root DEBUG error number None
06/18/2014 14:59:51 root DEBUG Error message: File not found or not valid dataset type at:
06/18/2014 14:59:51 root DEBUG Exception not disk-space related
06/18/2014 14:59:51 root DEBUG Printing traceback
Traceback (most recent call last):
File "invest_natcap\iui\executor.pyc", line 523, in runModel
File "invest_natcap\carbon\carbon_combined.pyc", line 20, in execute
File "invest_natcap\carbon\carbon_combined.pyc", line 84, in execute_30
File "invest_natcap\carbon\carbon_biophysical.pyc", line 24, in execute
File "invest_natcap\carbon\carbon_biophysical.pyc", line 89, in execute_30
File "invest_natcap\carbon\carbon_biophysical.pyc", line 289, in _compute_carbon_pools
File "invest_natcap\carbon\carbon_biophysical.pyc", line 328, in _compute_cell_area_ha
File "invest_natcap\raster_utils.pyc", line 204, in get_cell_size_from_uri
IOError: File not found or not valid dataset type at:
None

06/18/2014 14:59:51 root ERROR Exiting due to failures



I don't really understand it as it doesn't say where the error is...

Please help!
Thank you
Post edited by admin on

Comments

  • Hi,

    Would you mind attaching your input data so I can take a quick look to see where the problem is occurring?

    Thank you,

    Brad
  • yshennanyshennan Member
    edited June 2014
    Sure,

    I am trying to upload the .ovr file (grid) and the .csv file for the carbon budgets but both files give me an error, saying 'upload file type is not allowed'

    How can I upload them?

    thanks
    Post edited by yshennan on
  • You should be able to zip the files and add them as an attachment to this reply using "Attach a file" (located right below the text box which replies to this comment).

    Cheers,

    Brad
  • Here are the files:
  • I received the table but the only portion of the raster file that uploaded seems to be the metadata file. Could you please export the raster to a separate folder then zip the folder and attach it? Thank you.
  • Sure, see if this works
  • Unfortunately, the zip file only contained the .ovr file. Could you please also attach the .tiff file? Thank you.
  • Sorry, I thought the OVR file was the grid and could be used in the InVEST model. I have attached a TIFF now. Should I use TIFF format for all InVEST model input grids?

    Thank you
  • You can use either TIFF or GRID. If you use a GRID format, you will have to point to the .adf file within the raster directory.

    Good news is I was able to run your data and get results. Even better, I just talked to James, our software engineer, and he figured out the problem. It seems like the model is searching for a future LULC, which can be a glitch in the user interface where the model thinks the sequestration option is checked. If this happens, just check the sequestration option on and then off and try running the model. Please let us know if this solves the problem.

    Thank you,

    Brad and James
  • Hi Brad and James,

    Thank you for your help, this fixed the problem!

    Yara
This discussion has been closed.