This forum is shutting down! Please post new discussions at community.naturalcapitalproject.org

Non-square pixels error

sniffadogsniffadog Member
edited April 2014 in Terrestrial Models
Hi, in version 3.0.0 standalone sediment retention, I am getting Error: non-square pixels. They differ by a very small fraction around 0.1m
This was not a problem in 2.6.0 or earlier versions ? Is there something I can do to rectify this.
I am concerned that if I resample further the raster I will change info.
thx B.

Comments

  • RichRich Administrator, NatCap Staff
    Oh this is so interesting. All the routing algorithms depend on the fact that pixels are square and can get some interesting results if they're not. Until now, we hadn't experienced raster data at natcap with non-square pixels so in previous versions of InVEST we didn't check for this, and in the most recent release I decided to add that error on a rare chance it occurred, and apparently it did. Can you post your data so I can take a look?

    In the next release I'll change that error to a warning. If it's just a small amount then the results won't be off by that much.
  • Hi,
    I'll try to post up some data. I got around the issue by resampling in GRASS, nearest neighbour and aligning the bounds to the resolution, which guarantees the pixels are exactly square.
    Ben
  • RichRich Administrator, NatCap Staff
    FYI, I addressed this fix in the most recent nightly build. It'll be formally released in the next version of InVEST, but if you need to use it now you can:

    http://ncp-dev.stanford.edu/~dataportal/nightly-build/InVEST_dev103_3_0_0 [76cd28019086]_x86_Setup.exe
This discussion has been closed.