running Annual Water Yield model not ready after one day

Hi everyone

I am running the Annual Water Yield model. Everything goes fine, but after some time the log (see below) doesn't make any progress and stays like that for hours without any change. 
My study area is large (452 493 ha) so this could be part of the problem.

Could you give me some advice how to successfully run the model without this problem?

Thank you in advance!

Log: 
Initializing...

Showing messages with level INFO and higher

03/09/2019 12:55:28 natcap.invest.utils INFO Writing log messages to /Volumes/groot/actualThesis/thesis/Invest_MappingES_thesisGIS/INVEST/models with info study area/wateryieldmodel/inputspelen/InVEST-Hydropower-Water-Yield-log-2019-03-09--12_55_28.txt

03/09/2019 12:55:28 natcap.invest.ui.model Level 100 Starting model with parameters:

Arguments for InVEST natcap.invest.hydropower.hydropower_water_yield 3.5.0:

biophysical_table_uri /Volumes/groot/actualThesis/thesis/Invest_MappingES_thesisGIS/INVEST/models with info study area/wateryieldmodel/inputspelen/BPTABLEzelfingevuldewaarden.csv

calculate_valuation False

calculate_water_scarcity False

depth_to_root_rest_layer_uri /Volumes/groot/actualThesis/thesis/Invest_MappingES_thesisGIS/INVEST/models with info study area/wateryieldmodel/inputspelen/clipped and projected/brprocl/hdr.adf

eto_uri /Volumes/groot/actualThesis/thesis/Invest_MappingES_thesisGIS/INVEST/models with info study area/wateryieldmodel/inputspelen/clipped and projected/petprocl/hdr.adf

lulc_uri /Volumes/groot/actualThesis/thesis/Invest_MappingES_thesisGIS/INVEST/models with info study area/wateryieldmodel/inputspelen/clipped and projected/classprocl/hdr.adf

pawc_uri /Volumes/groot/actualThesis/thesis/Invest_MappingES_thesisGIS/INVEST/models with info study area/wateryieldmodel/inputspelen/clipped and projected/wcpr_clip/hdr.adf

precipitation_uri /Volumes/groot/actualThesis/thesis/Invest_MappingES_thesisGIS/INVEST/models with info study area/wateryieldmodel/inputspelen/clipped and projected/meanprprocl/hdr.adf

results_suffix

seasonality_constant 10

sub_watersheds_uri /Volumes/groot/actualThesis/thesis/Invest_MappingES_thesisGIS/INVEST/models with info study area/wateryieldmodel/inputspelen/clipped and projected/swshedprocl.shp

watersheds_uri /Volumes/groot/actualThesis/thesis/Invest_MappingES_thesisGIS/INVEST/models with info study area/wateryieldmodel/inputspelen/clipped and projected/wshedprocl.shp

workspace_dir /Volumes/groot/actualThesis/thesis/Invest_MappingES_thesisGIS/INVEST/models with info study area/wateryieldmodel/inputspelen


03/09/2019 12:55:28 natcap.invest.hydropower.hydropower_water_yield INFO Validating arguments

03/09/2019 12:55:28 pygeoprocessing.geoprocessing INFO n_workers > 1 (2) so starting a processes pool.

03/09/2019 12:55:29 natcap.invest.ui.usage._log_model WARNING an exception encountered when logging URLError(SSLError(1, u'[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:661)'),)

03/09/2019 12:55:40 pygeoprocessing.geoprocessing INFO 1 of 5 aligned: eto.tif

Comments

  • bpbryantbpbryant Member
    Hi Eva -- 

    I'm not an expert on any of this but here are two interim responses:

    1) It looks like you're using InVEST 3.5.0, so first perhaps try upgrading to the latest version 3.6.0 and see if the issue is still there. 
    2) If there's still an issue after that, the physical area of the landscape (ie, in hectares) is less important for runtime than the the dimensions of your lulc in terms of pixels. So, to get a better idea of whether it's an unreasonable runtime we'd need to know how many pixels are on each side (and/or the size of the pixels), so perhaps report that back if you still have trouble (along with the updated log file). 

    Hopefully that gets you started. 
  • Hi 

    Thank you for your answer!

    I installed version 3.6.0 on my Mac and tried to run it again. But the running remains super slow. See log below.
    My LULC raster has pixel size 4.28 meters. I need the high resolution because I need high resolution results for my study area.

    In addition, I installed version 3.6.0 on a Windows 10 laptop and tried to run it, but for the water yield model I keep getting the same error: First it says the shortcut is broken and when I try to fix it, I get the following sentence 'This app can't run on your PC.'. I tried to uninstall it and reinstall it again, but the problem remains on Windows. 

    How can I successfully run the model?

    Thank you in advance!

    Log for Mac: 

    Initializing...

    Showing messages with level INFO and higher

    03/10/2019 11:18:41 natcap.invest.utils INFO Writing log messages to /Volumes/groot/actualThesis/thesis/Invest_MappingES_thesisGIS/INVEST/models with info study area/wateryieldmodel/inputspelen/InVEST-Hydropower-Water-Yield-log-2019-03-10--11_18_41.txt

    03/10/2019 11:18:41 natcap.invest.ui.model Level 100 Starting model with parameters:

    Arguments for InVEST natcap.invest.hydropower.hydropower_water_yield 3.6.0:

    biophysical_table_path /Volumes/groot/actualThesis/thesis/Invest_MappingES_thesisGIS/INVEST/models with info study area/wateryieldmodel/inputspelen/nuechtspelen/BPTABLEzelfingevuldewaarden.csv

    depth_to_root_rest_layer_path /Volumes/groot/actualThesis/thesis/Invest_MappingES_thesisGIS/INVEST/models with info study area/wateryieldmodel/inputspelen/nuechtspelen/projected and clipped/brmmprcl/hdr.adf

    do_scarcity_and_valuation False

    eto_path /Volumes/groot/actualThesis/thesis/Invest_MappingES_thesisGIS/INVEST/models with info study area/wateryieldmodel/inputspelen/nuechtspelen/projected and clipped/petprocl/hdr.adf

    lulc_path /Volumes/groot/actualThesis/thesis/Invest_MappingES_thesisGIS/INVEST/models with info study area/wateryieldmodel/inputspelen/clipped and projected/classprocl/hdr.adf

    n_workers -1

    pawc_path /Volumes/groot/actualThesis/thesis/Invest_MappingES_thesisGIS/INVEST/models with info study area/wateryieldmodel/inputspelen/nuechtspelen/projected and clipped/wcawedivclpro/hdr.adf

    precipitation_path /Volumes/groot/actualThesis/thesis/Invest_MappingES_thesisGIS/INVEST/models with info study area/wateryieldmodel/inputspelen/nuechtspelen/projected and clipped/meanprprocl/hdr.adf

    results_suffix nuechtsp

    seasonality_constant 8

    sub_watersheds_path /Volumes/groot/actualThesis/thesis/Invest_MappingES_thesisGIS/INVEST/models with info study area/wateryieldmodel/inputspelen/nuechtspelen/projected and clipped/swshedprocl.shp

    watersheds_path /Volumes/groot/actualThesis/thesis/Invest_MappingES_thesisGIS/INVEST/models with info study area/wateryieldmodel/inputspelen/nuechtspelen/projected and clipped/wshedprocl.shp

    workspace_dir /Volumes/groot/actualThesis/thesis/Invest_MappingES_thesisGIS/INVEST/models with info study area/wateryieldmodel/inputspelen


    03/10/2019 11:18:41 natcap.invest.hydropower.hydropower_water_yield INFO Validating arguments

    03/10/2019 11:18:41 pygeoprocessing.geoprocessing INFO n_workers > 1 (2) so starting a processes pool.

    03/10/2019 11:18:42 natcap.invest.ui.usage._log_model WARNING an exception encountered when logging URLError(SSLError(1, u'[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:661)'),)


  • Eva_ToebatEva_Toebat Member
    edited March 10
    Hi

    I tried to run only a part of the study area and this worked!

    However, I am in doubt how to divide the study area in parts in a logical way.

    In my case the study area is situated in different watersheds, but never includes a whole watershed.
    I only have data for the study area, so running the model for each of the bigger watersheds is difficult.

    Does it make sense to run the model for each the parts of the watersheds situated in the study area?
    I included a map of my study area (red line) and the different watersheds in different colours.
    I also add a map with the study area and the sub watersheds in the next message.

    It would help me a lot to get some advice about this. 

    Thank you in advance!

    Kind regards

    Eva
    448 x 287 - 29K
    Post edited by Eva_Toebat on


  • SEE PREVIOUS MESSAGE
    538 x 409 - 70K
  • Hi Eva -- 

    I'll have to bow out here, but two things:
    1) Ok, yes, that is a large raster! You say you "need" the high resolution results for your study area, but I encourage you to consider that carefully. If all your inputs are not reliably varying at that fine a scale anyway, you may not be getting a lot of extra resolution in terms of outputs you can trust, it may just be false precision. At minimum, you could aggregate your inputs for initial runs to work out any other issues with the workflow, and then start refining them back for your "final" runs.  

    Dividing the area by watershed is the way to go. I'm not sure how to deal with the issue of not having the whole watershed for any of them, but I can say that's a problem regardless of whether you run the entire AOI at once or not, so you might as well separate it. You'll have to get help from a hydrologist to figure out the partial watershed problem. The best way I can think of is to run it on alternate data (at worst, globally available) data that does cover the whole watershed, but there may be other ways to handle it depending on your interest. 

    Good luck!
    -Ben

     
  • Hi Ben

    Thank you for the quick answer and advice!

    I just noticed the subsubwatersheds are completely in the study area. 
    The watersheds area really large. Therefore, I was thinking to use the sub watersheds as input for the watersheds part  in the model and the subsubwatersheds as input for the sub watersheds part in the model. Would this make sense or is the model really built for watersheds and sub watersheds?

    Thank you in advance!

    Kind regards

    Eva
  • jdouglassjdouglass Administrator, NatCap Staff
    @Eva_Toebat, I'm glad you were able to get the model to run on a part of your study area!

    I'm a little concerned that InVEST won't run on your Windows laptop, though.  Could you screenshot the 'This app can't run on your PC' error and post it here?
  • Hi

    1) I open InVEST 3.6.0 and click on the Water Yield shortcut --> "Windows is searching for invest.exe. To locate the file yourself, Click Browse" (other option was Cancel)
    2) I click on Browse and try to find the file: I find one folder named InVEST with names of some models in it. But the Water Yield model is not mentioned. 
    3) When I wait and don't click on 'browse' the following window appears: 
    'Problem with shortcut: The item 'invest.exe' that this shortcut refers to has been changed or moved, so this shortcut will no longer work properly. etc' (see attached file). 
    When I click on 'fix it' --> see attached file 2:  'this app can't run on your PC'

    When I try to open another model to see if this will work, for example the carbon model: I get the same as above.
    480 x 360 - 51K
    1920 x 1080 - 181K
  • jdouglassjdouglass Administrator, NatCap Staff
    Very interesting!  The only other time I've seen something like this is when an antivirus program (usually Norton or McAfee) has quarantined invest.exe.  Could you check and see if your antivirus has done so?  If so, the solution would be to whitelist the application within your antivirus.

    Hopefully that'll do the trick!  If it doesn't, let us know and we'll keep debugging.
    James
Sign In or Register to comment.