This forum is shutting down! Please post new discussions at community.naturalcapitalproject.org

SDR Error

Hello together,
I ran a few scenarios with InVEST 3.5. and all worked well. Then I took another biophysical table and I got an error called "RuntimeError: stats_worker_thread.join() timed out". I tried to use the new version 3.6. and again it ran for a few hours and then had an error called "AttributeError: 'NoneType' object has no attribute 'RasterCount'".

Can you help me with the problem? I attached both log files.

Comments

  • jdouglassjdouglass Administrator, NatCap Staff
    It's hard to say what might be causing the issue here.  Could you send your inputs (with the failing biophysical table) to jdouglass@stanford.edu so I can take a look?

    Thanks,
    James
  • Hi hillel,

    I do not know if it is happens in your case too. I had same error when running NDR, then I found that I forgot to create a field in watershed map. After adding ws_id column, my model ran fine. 
  • jdouglassjdouglass Administrator, NatCap Staff
    @urgendalai, thanks for posting on this thread!  Hopefully your fix will address the issue here as well.
  • Hello together!
    Since I could already run the model with other inputs, it is not a problem with the watershed file. It didn't change between runs and I definitely have the ws_id column. But what is weird is the following: I wanted to rerun the model with a biophysical table that already worked before and an adapted SDRmax value. I renamed the suffix to suit the biophysical table and the changed SDRmax to "erecin_1000_0.6". But I forgot to change the path to the table so the model ran with the exact table that gave the error described above and everything worked fine! I thought maybe the issue would be fixed and tried to use the difficult table again with the default SDRmax value and named the suffix "vanderknijff_1000_0.8" but than it again gave the described error. Is it somehow possible that the problem has something to do with te length of the suffix? I will now pack a .zip for you jdouglass and send it to you for taking a look.

    Lisa
  • Hello James,
    I sent you my input files to the mail you mentioned above. Did they reach you?

    Lisa
  • jdouglassjdouglass Administrator, NatCap Staff
    Hi Lisa, They did, yes!  I'm hoping to dig into them today.
  • GabiTDGabiTD Member
    Hi all,
    I am having a very similar issue, but more previously on my log file. The model just run the first steps and than I get the same error message.
    James, if it is ok for you, I can send my inputs for you to take a look, because I have been trying to find the answer by myself and did not got any luck. I have a deadline to send the outputs of this model (and another scenario) and I need all the help I can get.
    Best,
    Gabi  
  • swolnyswolny Member, NatCap Staff
    Hi Gabi -

    Just letting you know that we're all out at a conference this week, so it might be a while before James is able to respond.

    ~ Stacie

  • jdouglassjdouglass Administrator, NatCap Staff
    @hillel_95, I just wrote back to you over email about the issue.

    @GabiTD, your logfile does indeed look like a similar (if not the same) issue.  We've very recently made some changes to SDR that haven't made it out in a full InVEST release just yet.  Could you try this development build and see if that resolves things for you?  Here's the download link: https://storage.googleapis.com/releases.naturalcapitalproject.org/invest/3.6.0.post204+hb4caaf03e97b/InVEST_3.6.0.post204+hb4caaf03e97b_x86_Setup.exe

    Thanks,
    James
  • Hi @jdouglass I'm having the same error with SDR model, RuntimeError: stats_worker_thread.join() timed out ,
    as you can see in my log file. I tried to use the link you provided, but it says it has no object associated. Can you help me solve this problem?
  • rukundorukundo Member
    Hello team,
    Am running SDR model and i keep getting this error" AttributeError: 'NoneType' object has no attribute 'GetRasterBand'
    Can you help???

    Thanks
  • swolnyswolny Member, NatCap Staff
    Hi @rukundo -

    If you look at the first ERROR, it says this, 

    "ERROR    [errno 3] Free disk space available is 865726464 bytes, whereas 1205404904 are at least necessary. You can disable this check by defining the CHECK_DISK_FREE_SPACE configuration option to FALSE." 

    So it looks like you don't have enough disk space, which could lead to the Attribute Error you noted.

    ~ Stacie
  • jdouglassjdouglass Administrator, NatCap Staff
    @SU_Martins, we just recently made some changes to SDR that might well fix this issue.  Could you try running the development build of InVEST linked below and see if that fixes the issue?


    Thanks,
    James
  • rukundorukundo Member
    Hi Stacie,
    I think I have got enough space, but let me try to increase the it and see if it can work


    thanks
  • @jdouglass, thanks for the quick answer, but like the previous link, this one send a XML with this on:
    <Error>
    <Code>NoSuchKey</Code>
    <Message>The specified key does not exist.</Message><Details>No such object: releases.naturalcapitalproject.org/invest/3.6.0.post204+hb4caaf03e97b/InVEST_3.6.0.post204+hb4caaf03e97b_x86_Setup.exe</Details>
    </Error>

    Susana
  • jdouglassjdouglass Administrator, NatCap Staff
  • Thank you so much James, it worked :)
     
    Susana
Sign In or Register to comment.