This forum is shutting down! Please post new discussions at community.naturalcapitalproject.org

The following land cover codes were found in the sensitivity table.

Hi guys
I am an InVEST user from 4 years ago. I have installed the 3.6 version today and performed the Habitat Quality model but encountered with this error: "The following land cover codes were found in the sensitivity table. Check your sensitivity table to see if they are missing: 255". 
I performed the Habitat Quality model in the 3.5 version with same data already but I didn't encounter with any error. what is the problem in your opinion?

Thanks

Comments

  • jdouglassjdouglass Administrator, NatCap Staff
    It sounds like your landcover raster has a pixel value of 255, but the value 255 is missing from your sensitivity table.  So, if the value of 255 is supposed to be a valid landcover code, you'll need to add 255 to the sensitivity table.  If the value of 255 is supposed to represent nodata, you'll need to set the nodata value of your raster accordingly.

    Hope this helps,
    James
  • thank you, James,
    I did this work and add the 255 to the sensitivity table. after this model performed but I didn't receive good results.
  • jdouglassjdouglass Administrator, NatCap Staff
    Hi, This came up on another forums thread as well.  It would seem that the Habitat Quality model is missing a case in its error checking where the presence of a nodata value isn't handled properly.  Our build infrastructure is down at the moment, but I hope to have a development build for you to try in the near future.
  • jdouglassjdouglass Administrator, NatCap Staff

    I'm sorry about the delay on this, but there did indeed look to be an issue in the Habitat Quality model that was causing this error.  Could you try the development build below on your original inputs (without the 255 added to your sensitivity table)?


    Hopefully that'll do the trick.
    James
  • edited March 13
    Hi Dear @jdouglass

    Many thanks for your favor. I uninstalled the 3.6 version and reinstalled the 3.5 and performed my inputs with this version and didn't encounter any error.
    Ali

    Post edited by alirezadaneshi on
Sign In or Register to comment.