Habitat Quality Question

Hi everyone

I
have some problems when running the habitat quality
model (InVEST 3.4.4), I got a “model completed successfully” but there was another
error [Errno 10060]

I have input the whole map and all the threats that cover the map,
but the generated result only shows a piece of the map.

 

__________________________

Initializing...

Showing messages with level INFO and higher

01/09/2019 16:01:24 natcap.invest.utils INFO Writing log messages
to D:\HZ\TEST_12_12_4\InVEST-Habitat-Quality-log-2019-01-09--16_01_23.txt

01/09/2019 16:01:24 natcap.invest.ui.usage._log_model WARNING an
exception encountered when logging AttributeError("'NoneType' object has
no attribute 'ExportToWkt'",)

01/09/2019 16:01:24 natcap.invest.ui.model Level 100 Starting
model with parameters:

Arguments for InVEST natcap.invest.habitat_quality 3.4.4:

half_saturation_constant 0.5

landuse_cur_uri D:/HZ/TEST_12_12_4/LUCC_c.tif

results_suffix

sensitivity_uri D:/HZ/TEST_12_12_4/sensitivity.csv

threat_raster_folder D:\HZ\TEST_12_12_4\input

threats_uri D:/HZ/TEST_12_12_4/threats.csv

workspace_dir D:\HZ\TEST_12_12_4

 

01/09/2019 16:01:24
natcap.invest.pygeoprocessing_0_3_3.geoprocessing INFO starting convolve

01/09/2019 16:01:29
natcap.invest.pygeoprocessing_0_3_3.geoprocessing INFO starting convolve

01/09/2019 16:01:32
natcap.invest.pygeoprocessing_0_3_3.geoprocessing INFO starting convolve

01/09/2019 16:01:34
natcap.invest.pygeoprocessing_0_3_3.geoprocessing INFO starting convolve

01/09/2019 16:01:36
natcap.invest.pygeoprocessing_0_3_3.geoprocessing INFO starting convolve

01/09/2019 16:01:37
natcap.invest.pygeoprocessing_0_3_3.geoprocessing INFO starting convolve

01/09/2019 16:01:41 natcap.invest.habitat_quality INFO Baseline
not provided to compute Rarity

01/09/2019 16:01:41 natcap.invest.ui.model INFO Execution finished

01/09/2019 16:01:41 natcap.invest.utils INFO Elapsed time: 16.83s

01/09/2019 16:01:41 natcap.invest.ui.execution INFO Execution
finished

01/09/2019 16:02:05 natcap.invest.ui.usage._log_exit_status
WARNING an exception encountered when _log_exit_status <urlopen error [Errno
10060]

_________________________________

   I will be very grateful
with your help

869 x 601 - 53K
756 x 653 - 86K

Comments

  • swolnyswolny Member, NatCap Staff
    Hi @Packy -

    Thank you for including the log and image of the output. I think you don't need to worry about the final WARNING, it shouldn't affect the result.

    For the result not covering the whole area, is it possible that one of your threats (or other input) layers only covers the area where you got output? If so, try recreating that threat layer so that it covers the whole land use/land cover map, and make sure that all cells have a value of either 0 (if the threat is not present) or a value between 0 and 1 if the threat is present.

    ~ Stacie
  • PackyPacky Member
    Hi @swolny Thank you for your help. I have got the correct result that cover the whole area,but now I have anthor problem that the values of  Habitat Degradation Map are not at range of 0-1 and the values are concentrated at only one level.
    _________________________

    Initializing...

    Showing messages with level
    INFO and higher

    01/10/2019 20:42:54
    natcap.invest.utils INFO Writing log messages to
    D:\HZ\TEST_01-10_1\InVEST-Habitat-Quality-log-2019-01-10--20_42_54.txt

    01/10/2019 20:42:54
    natcap.invest.ui.usage._log_model WARNING an exception encountered when logging
    AttributeError("'NoneType' object has no attribute 'ExportToWkt'",)

    01/10/2019 20:42:54
    natcap.invest.ui.model Level 100 Starting model with parameters:

    Arguments for InVEST
    natcap.invest.habitat_quality 3.4.4:

    half_saturation_constant 0.5

    landuse_cur_uri
    D:/HZ/TEST_01-10_1/LUCC_c.tif

    results_suffix

    sensitivity_uri
    D:/HZ/TEST_01-10_1/sensitivity.csv

    threat_raster_folder
    D:\HZ\TEST_01-10_1\input

    threats_uri
    D:/HZ/TEST_01-10_1/threats.csv

    workspace_dir D:\HZ\TEST_01-10_1

     

    01/10/2019 20:42:55
    natcap.invest.pygeoprocessing_0_3_3.geoprocessing INFO starting convolve

    01/10/2019 20:43:20
    natcap.invest.pygeoprocessing_0_3_3.geoprocessing INFO starting convolve

    01/10/2019 20:43:55
    natcap.invest.pygeoprocessing_0_3_3.geoprocessing INFO starting convolve

    01/10/2019 20:44:31
    natcap.invest.pygeoprocessing_0_3_3.geoprocessing INFO starting convolve

    01/10/2019 20:44:59
    natcap.invest.pygeoprocessing_0_3_3.geoprocessing INFO convolution operating on
    signal pixel (0, 768)

    01/10/2019 20:45:22
    natcap.invest.pygeoprocessing_0_3_3.geoprocessing INFO starting convolve

    01/10/2019 20:45:40
    natcap.invest.pygeoprocessing_0_3_3.geoprocessing INFO starting convolve

    01/10/2019 20:45:58
    natcap.invest.pygeoprocessing_0_3_3.geoprocessing INFO starting convolve

    01/10/2019 20:46:24
    natcap.invest.pygeoprocessing_0_3_3.geoprocessing INFO align_dataset_list
    aligning dataset 6 of 15

    01/10/2019 20:46:29
    natcap.invest.pygeoprocessing_0_3_3.geoprocessing INFO align_dataset_list
    aligning dataset 12 of 15

    01/10/2019 20:46:36
    natcap.invest.habitat_quality INFO Baseline not provided to compute Rarity

    01/10/2019 20:46:36
    natcap.invest.ui.model INFO Execution finished

    01/10/2019 20:46:36
    natcap.invest.utils INFO Elapsed time: 3m 41.79s

    01/10/2019 20:46:36 natcap.invest.ui.execution
    INFO Execution finished

    01/10/2019 20:46:57
    natcap.invest.ui.usage._log_exit_status WARNING an exception encountered when
    _log_exit_status [Errno socket error] [Errno 10060]

     ___________________________________________________


    813 x 591 - 38K
    669 x 645 - 8K
Sign In or Register to comment.