Recreation model Error 10060

Hi Forum members

Just a quick question about the recreation model. I'm interested in recreational value in China, Fujian Province. When I try to run the model I get the following error message:

ConnectionClosedError: receiving: connection lost: [Errno 10060] 

I tried to use another computer and the same error occurred. Is that because of my connection or something else?
 I am attaching the log here:

01/06/2019 14:21:49  natcap.invest.utils INFO     Writing log messages to E:\Research\Graduation\FJDataCollection\FJInVESTSource\Recreation\InVEST-Recreation-Model-log-2019-01-06--14_21_49.txt
01/06/2019 14:21:49  natcap.invest.ui.model Level 100 Starting model with parameters: 
Arguments for InVEST natcap.invest.recreation.recmodel_client 3.5.0:
aoi_path           E:/Research/Graduation/FJDataCollection/CountiesSource/Fujian_Polygon.shp
cell_size          2500
compute_regression False
end_year           2010
grid_aoi           True
grid_type          square
results_suffix     
start_year         2010
workspace_dir      E:\Research\Graduation\FJDataCollection\FJInVESTSource\Recreation

01/06/2019 14:22:15  natcap.invest.recmodel_client INFO     Contacting server, please wait.
01/06/2019 14:22:16  natcap.invest.recmodel_client INFO     Server online, version: 3.3.2:./recserver_cache_2017/76e890d2cf86640e_fast_hash.pickle
01/06/2019 14:22:16  natcap.invest.recmodel_client INFO     Server supports year queries between 2005 and 2017
01/06/2019 14:22:16  natcap.invest.recmodel_client INFO     gridding aoi
01/06/2019 14:22:24  natcap.invest.recmodel_client INFO     archiving E:\Research\Graduation\FJDataCollection\FJInVESTSource\Recreation\aoi.prj
01/06/2019 14:22:24  natcap.invest.recmodel_client INFO     archiving E:\Research\Graduation\FJDataCollection\FJInVESTSource\Recreation\aoi.shp
01/06/2019 14:22:24  natcap.invest.recmodel_client INFO     archiving E:\Research\Graduation\FJDataCollection\FJInVESTSource\Recreation\aoi.shx
01/06/2019 14:22:24  natcap.invest.recmodel_client INFO     archiving E:\Research\Graduation\FJDataCollection\FJInVESTSource\Recreation\aoi.dbf
01/06/2019 14:22:24  natcap.invest.recmodel_client INFO     Please wait for server to calculate PUD...
01/06/2019 14:22:46  natcap.invest.ui.model ERROR    Exception while executing <function execute at 0x1665B5B0>
Traceback (most recent call last):
  File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\env\lib\site-packages\natcap\invest\ui\model.py", line 1541, in _logged_target
  File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\env\lib\site-packages\natcap\invest\recreation\recmodel_client.py", line 229, in execute
  File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\env\lib\site-packages\Pyro4\core.py", line 171, in __call__
  File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\env\lib\site-packages\Pyro4\core.py", line 410, in _pyroInvoke
  File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\env\lib\site-packages\Pyro4\message.py", line 168, in recv
  File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\env\lib\site-packages\Pyro4\socketutil.py", line 438, in recv
  File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\env\lib\site-packages\Pyro4\socketutil.py", line 180, in receiveData
ConnectionClosedError: receiving: connection lost: [Errno 10060] 
01/06/2019 14:22:46  natcap.invest.ui.model INFO     Execution finished
01/06/2019 14:22:46  natcap.invest.utils INFO     Elapsed time: 56.54s

Thanks everyone. 

Meyer

Comments

  • DaveDave Member, Administrator, NatCap Staff
    Thanks for posting. We see these connection errors from time to time and it's hard to explain why. You can search for "communicationerror" on this forum and see some of those other threads for possible explanations. 

    Is it possible for you to try from a different network? 
  • Thanks, Dave, I solved this problem by using my own hot spot and closing the firewall! I was at first using our university's network, which might have caused the error. You have been really helpful. Good luck everyone. 
  • DaveDave Member, Administrator, NatCap Staff
    Thanks for the feedback! It's useful to hear how these issues get resolved since they tend to be specific to each individual's setup.

    Glad it's working for you!
Sign In or Register to comment.