Hydropower water yield

Hi¡ I'm running the hydropower water yield and I havethis error with the model:

Traceback (most recent call last):

File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\env\lib\site-packages\natcap\invest\ui\model.py", line 1541, in _logged_target

File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\env\lib\site-packages\natcap\invest\hydropower\hydropower_water_yield.py", line 462, in execute

File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\env\lib\site-packages\natcap\invest\hydropower\hydropower_water_yield.py", line 906, in _add_zonal_stats_dict_to_shape

KeyError: 1001019008

12/26/2018 07:28:58 natcap.invest.ui.model INFO Execution finished

12/26/2018 07:28:58 natcap.invest.utils INFO Elapsed time: 2.87s

12/26/2018 07:28:58 natcap.invest.ui.execution ERROR Target <function _logged_target at 0x12BC0BF0> failed with exception

Traceback (most recent call last):

File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\env\lib\site-packages\natcap\invest\ui\execution.py", line 68, in run

File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\env\lib\site-packages\natcap\invest\ui\model.py", line 1541, in _logged_target

File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\env\lib\site-packages\natcap\invest\hydropower\hydropower_water_yield.py", line 462, in execute

File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\env\lib\site-packages\natcap\invest\hydropower\hydropower_water_yield.py", line 906, in _add_zonal_stats_dict_to_shape

KeyError: 1001019008

12/26/2018 07:28:58 natcap.invest.ui.execution INFO Execution finished



I don't know what can I do. Could you help me?


Thank you very much

Comments

  • swolnyswolny Member, NatCap Staff
    Hi @csancho -

    If you search this forum for "KeyError", you'll find a lot of other posts from people who have gotten this error too, and how they fixed it. See if any of those help, and if not, let us know what you tried, and please post the whole .txt log file that the model creates, so we have more information to help troubleshoot.

    ~ Stacie
Sign In or Register to comment.