This forum is shutting down! Please post new discussions at community.naturalcapitalproject.org

SDR model error --> RuntimeError: stats_worker_thread.join() timed out

Comments

  • RichRich Administrator, NatCap Staff
    Hi, I'm working on a development version of SDR that's a whole lot faster and fixes some bugs in previous versions. Would you be willing to try it and see if it resolves your issue? You can download it here: http://data.naturalcapitalproject.org/nightly-build/invest-forks/richsharp/InVEST_3.5.0.post676+h935334e85589_x86_Setup.exe
  • A_MedinaA_Medina Member
    edited November 2018
    Ok
    Post edited by A_Medina on
  • A_MedinaA_Medina Member
    edited November 2018
    Hello Rich,

    I've worked in that version and still having the same result... 

    RuntimeError encountered: stats_worker_thread.join() timed out

    There are maps of stream and USLE (both seem to be OK) though. I think the problem could be in the second component of the calculation (in the IC to be more precise) since I found this in the log (look at the attacment) ---> Runtime warning: Divide by zero encountered in log 10  

    What do you suggest to do now?
    Thanks in advance for your insights.

    Alicia

    1056 x 834 - 139K
    Post edited by A_Medina on
  • RichRich Administrator, NatCap Staff
    Hi Alicia, the log and those error messages look like they're coming from a different version of InVEST than what I sent you. Specifically anything with a pygeoprocessing_0_3_3 is a clue that it's an old version. Could you make sure any other versions of InVEST you have installed are uninstalled first and then try this very new version I built today? http://data.naturalcapitalproject.org/nightly-build/invest-forks/richsharp/InVEST_3.5.0.post708+he11ff7c9758f_x86_Setup.exe

    And if you still get errors could you please attach the text log along with a screenshot of the error window?
  • Dear Rich,

    I got good and bad news running the new version (I did have a lot of care on uninstalling the other versions BTW)... 

    - I ran successfully the watersheds that (for any reason. which I attributed to my DEM) I wasn't able before
    - Running the whole study area didn't work (same message than screemshoot attached)  
    - I can run successfully the model for some groups of watersheds, like this one: https://www.dropbox.com/s/63rrihqi4xuvnmo/sdr_datastack.invest.tar.gz?dl=0
    - But, I can not do it for some others, like this for example: https://www.dropbox.com/s/crw407sd55hf6jp/ERRORsdr_datastack.invest.tar?dl=0
    I had an Error message (screemshoot attached), which I found completely weird because I use the same datasets for running the succesful ones... I just changed the group of watersheds and got this error message. Rasters not aligned? No sense. 

    Let me know what are your comments about this. 
    Best,
    Alicia
    1264 x 1087 - 164K
  • Rich,
    I forgot to tell you that for those groups of watersheds that can't be run with this new version you recently sent me, I CAN DO it actually with the last version in the InVEST website.

    So... I don't understand at this point why if it's running correctly with one version, it's not running with this new one you sent and getting such an error?

    BR,
    Alicia
  • RichRich Administrator, NatCap Staff
    Hi Alicia, thanks so much for this report and the datastack that caused it. We implemented a new feature that uses the vector polygons to mask out regions of the input rasters to simplify calculation, but it seems that the polygons of your watershed had some bad geometry and caused the whole thing to mask out. I've removed that feature entirely and was able to run through your datastack with no problem. And I rolled that into yet another new development version of SDR. Would you be willing to try out this one? http://data.naturalcapitalproject.org/nightly-build/invest-forks/richsharp/InVEST_3.5.0.post709+hbc41e54bcc6c_x86_Setup.exe
Sign In or Register to comment.