Coastal Vulernability model error: No exposed shoreline segments found.

MonMon Member
I've been running the Coastal Vulnerability model (version 3.4.2) with sample data from InVEST and I keep getting the following error: "No exposed shoreline segments found. This could be from a too-high depth threshold or a too-low exposure proportion." I opened the sample data in ArcGIS. All of the files look like they are in the correct location, but the coordinate systems are mixed. 

I converted them all to NAD 1983 UTM Zone 10, except for Structures_BarkClay.shp. I was unable to open this in ArcGIS, and upon closer inspection, I saw that it did not have a .dbf file. I checked previous versions of InVEST (all the way back to 3.0) and could not find a .dbf file. I also checked a colleague's machine with version 3.5.0, and the .dbf is not there either. I'm wondering if this is the source of the error or it's something else. I am able to run the model with the Structures field left blank, but it gives the same error. 

Is it possible to get an updated Structures shapefile with the .dbf included? I'm hoping this plus having everything in the same projected coordinate system will fix the error, but if it doesn't, are there other places where I may be going astray?

Comments

  • DaveDave Member, NatCap Staff
    Hi Mon,

    I'm not able to reproduce this error using the sample data, but here are some general thoughts...

    It's safe to say the error is not caused by that Structures layer, which is optional, since you see the same error without it.

    Generally it is a good idea to keep all the data in the same coordinate system, though that's not a requirement for this model either - it should do the necessary transformations.

    There are some permission denied errors appearing the log. What happens if you try to the run the model in a fresh workspace that doesn't already exist?

    What happens if you upgrade to 3.5.0?
  • MonMon Member
    Hi Dave,

    We were trying to do it in 3.4.2 to prepare a lab for a GIS class, and that's the version that's imaged on all the class computers. I ran it in 3.5.0 with and without the structures layer, using a fresh workspace, and got the same message.

    I'm using Windows 7. I don't know if that matters regarding the error.
  • DaveDave Member, NatCap Staff
    Hi Mon, if you would like, you can send me your input data stack and I will try to reproduce the error. The original sample data and default parameters are working for me. You mentioned you projected many of the datasets to a UTM system. Were you experiencing this same error before doing that, with the original sample data? It could be worth trying the original sample data again, or send me the data you are actually working with (davefisher@stanford.edu). You could use dropbox or google drive, etc.
  • DaveDave Member, NatCap Staff
    It turns out this error was caused by the large value chosen for the 'Rays per Sector' parameter. The chosen value was 10, while the default setting is 1. That value - along with Exposure Proportion and Depth Threshold - controls whether points along the coast are categorized as 'exposed' or 'sheltered'. 

    An oversimplified explanation of what's happening: The model casts rays outward from each shore point in 16 cardinal directions (sectors) to determine if a point is sheltered or exposed. Setting a high 'rays per sector' then demands that an unrealistic number of those rays meet some other criteria related to the exposure proportion and depth threshold.

    Setting Rays per Sector = 1 avoids this error.
This discussion has been closed.