This forum is shutting down! Please post new discussions at

Error in SDR model


I'm running an SDR model. I am suppose to run 4 sets of SDR, with different LULC as scenarios. The first ran was successful but when I changed the bptable and lulc, i always get this error:

RuntimeError: stats_worker_thread.join() timed out

I am searching in the forums but i can't seem to find a similar case. 
Can you help me on this? I also attached the log file.



  • jdouglassjdouglass Administrator, NatCap Staff
    Hello,  There's a good chance this issue might have been fixed in the latest version of InVEST.  Could you try out InVEST 3.5.0 (download here: and see if it does fix it?  Let us know if it doesn't.

  • Hi,

    Thanks for the response.
    I'm actually using the 3.5 with this. Really appreciate all the assistance.
  • swolnyswolny Member, NatCap Staff
    Hi @carlueta -

    Would you please post the logfile from the 3.5 version run? The logfile you attached is from 3.4.4. Thanks!

    ~ Stacie

  • Hi Stacie and James, 

    Thanks for helping me out. Here's the latest logfile (I tried a rerun again and same thing happened). 

  • additional information, although I used the 3.5 version, for some reason, it's automatically reverting back to 4.4 since it is still installed in my system. Should I uninstall the 4.4 version?
  • Dear all, 

    just to make sure the reason was not a version issue, I uninstalled both the 3.4.4 and 3.5 versions then reinstall just the 3.5. 
    I still get a similar error. Here is the log file for your reference. 

    Hope this will help.

  • Hi, 

    I have made three runs of a similar model with different LC and bptable inputs to ensure that the error is not due to the dataset. I encountered exactly the same error for the three runs. Sharing the log file of the three runs if it might help in diagnosing the problem. 

    I also tried uninstalling all invest versions I have and installing only the 3.5 version, so the log files are from the 3.5 version. 

    Hope you can help me on this. 

    Many thanks!

  • swolnyswolny Member, NatCap Staff
    I'm not going to be much help on this issue, but do have a quick question: Is all of your input/output going to a local disk, or to a network drive?  If it's a network drive, can you try running it locally?

    Else, you can send me your data and I'll try it out.

    ~ Stacie

  • Hi Stacie,

    All data inputs and output folders were in local drive. I made a workaround and tried reducing all the dataset to 1 watershed only. It worked on a per watershed, but i get that error if i ran it in 5 WS.

    So i did a per WS then just mosaic and merge them after.

    I can send you the data if you want to check further.


  • swolnyswolny Member, NatCap Staff
    That's strange. Well, if you want me to look into it further then please do send your data. If not, then I'm glad that you found a workaround.

    ~ Stacie
  • Hi Stacie, 

    Thanks. I am still curious as to what really happened because I will be running a 20-30+ watershed later on. 
    How can I send you the dataset? The total folder size is 360MB so it might be difficult to attach it here in the forum. 

    Many thanks for your assistance. 

    ~ Carl
  • swolnyswolny Member, NatCap Staff
    You should be able to run it on multiple sub-watersheds, so yes, send me your data and I'll try running it. In the SDR app, do this:

    - File -> Save As
    - Datastack type: Data archive
    - Save the dataset 

    Then post it to Google Drive/Dropbox/whatever and send me the link. You can post it here or send to me at swolny at

    ~ Stacie

  • swolnyswolny Member, NatCap Staff
    Hi Carl -

    The problem seems to be that you have negative values in your erodibility (K) raster. I got the same error you did with the data you set, then I tried setting the negative K values to 0 and ran the model successfully on all watersheds at once. 

    Along with no negative values, you might want to check the units that you have for K, if they're metric they're usually < .1.

    ~ Stacie
  • Great! Thanks Stacie. Will do that and check K too. 
Sign In or Register to comment.