This forum is shutting down! Please post new discussions at community.naturalcapitalproject.org

Recreation 3.3.3 and 3.4.4 ERROR with the shp

Dear InVEST developers,

I'm trying to run the recreation model for a huge area composed of multiple polygons. When I try to run the model with the entire shp the log shows an error but it still runing without results yet. It takes a lot of time anyway. So that I tryed to run the model with different parts of the shp. The log shows always the same error:

LOG 1: with the entire shp

C:\InVEST_3.3.3_x86\invest-3-x86>.\invest.exe recreation
(<natcap.invest.iui.modelui.ModelUI object at 0x09E23A80>, 'setting super to None')
('lastrun URI:', u'recreation_lastrun_3.3.3.json')
10/01/2018 12:04:18  root                 DEBUG    Loading <module 'natcap.invest.recreation.recmodel_client' from 'C:\INVEST~1.3_X\INVEST~1\natcap\invest\recreation\recmodel_client.pyc'> in frozen environment
10/01/2018 12:04:18  root                 INFO     Logging will be saved to natcap.invest.recreation.recmodel_client-log-2018-10-01--12_04_18.txt
10/01/2018 12:04:19  root                 DEBUG    Loaded the model from natcap.invest.recreation.recmodel_client
10/01/2018 12:04:19  root                 INFO     Executing the loaded model
10/01/2018 12:04:19  root                 INFO     Running InVEST version "3.3.3"
10/01/2018 12:04:19  root                 INFO     Python architecture: ('32bit', 'WindowsPE')
10/01/2018 12:04:19  root                 INFO     Disk space remaining for workspace: 258.68 GB
10/01/2018 12:04:19  root                 INFO     Pointing temporary directory at the workspace at D:\Users\albertonk91\Desktop\UAM master\LIFE_FER\prueba_recre_3_3_3
ERROR 4: `D:/Users/albertonk91/Desktop/UAM master/LIFE_FER/dis_zepa_lic_intemares.shp' not recognised as a supported file format.

10/01/2018 12:04:19  root                 INFO     Starting natcap.invest.recreation.recmodel_client
ERROR 4: `D:\Users\albertonk91\Desktop\UAM master\LIFE_FER\prueba_recre_3_3_3' not recognised as a supported file format.

10/01/2018 12:04:19  root                 INFO     Setting tempfile.tempdir to D:\Users\albertonk91\Desktop\UAM master\LIFE_FER\prueba_recre_3_3_3\tmp
10/01/2018 12:04:19  natcap.invest.recmodel_client INFO     Contacting server, please wait.
10/01/2018 12:04:19  natcap.invest.recmodel_client INFO     Server online, version: 3.3.2:./recserver_cache_2017/76e890d2cf86640e_fast_hash.pickle
10/01/2018 12:04:20  natcap.invest.recmodel_client INFO     Server supports year queries between 2005 and 2017
10/01/2018 12:04:20  natcap.invest.recmodel_client INFO     gridding aoi
10/01/2018 12:12:45  natcap.invest.recmodel_client INFO     archiving D:\Users\albertonk91\Desktop\UAM master\LIFE_FER\prueba_recre_3_3_3\aoi.prj
10/01/2018 12:12:45  natcap.invest.recmodel_client INFO     archiving D:\Users\albertonk91\Desktop\UAM master\LIFE_FER\prueba_recre_3_3_3\aoi.shp
10/01/2018 12:12:45  natcap.invest.recmodel_client INFO     archiving D:\Users\albertonk91\Desktop\UAM master\LIFE_FER\prueba_recre_3_3_3\aoi.shx
10/01/2018 12:12:45  natcap.invest.recmodel_client INFO     archiving D:\Users\albertonk91\Desktop\UAM master\LIFE_FER\prueba_recre_3_3_3\aoi.dbf
10/01/2018 12:12:45  natcap.invest.recmodel_client INFO     Please wait for server to calculate PUD...

LOG 2: only with few polygons

C:\InVEST_3.3.3_x86\invest-3-x86>.\invest.exe recreation
(<natcap.invest.iui.modelui.ModelUI object at 0x09A84A80>, 'setting super to None')
('lastrun URI:', u'recreation_lastrun_3.3.3.json')
10/01/2018 14:31:23  root                 DEBUG    Loading <module 'natcap.invest.recreation.recmodel_client' from 'C:\INVEST~1.3_X\INVEST~1\natcap\invest\recreation\recmodel_client.pyc'> in frozen environment
10/01/2018 14:31:23  root                 INFO     Logging will be saved to natcap.invest.recreation.recmodel_client-log-2018-10-01--14_31_23.txt
10/01/2018 14:31:23  root                 DEBUG    Loaded the model from natcap.invest.recreation.recmodel_client
10/01/2018 14:31:23  root                 INFO     Executing the loaded model
10/01/2018 14:31:23  root                 INFO     Running InVEST version "3.3.3"
10/01/2018 14:31:23  root                 INFO     Python architecture: ('32bit', 'WindowsPE')
10/01/2018 14:31:23  root                 INFO     Disk space remaining for workspace: 258.56 GB
10/01/2018 14:31:23  root                 INFO     Pointing temporary directory at the workspace at D:\Users\albertonk91\Desktop\UAM master\LIFE_FER\prueba_recre_3_3_3
ERROR 4: `D:/Users/albertonk91/Desktop/UAM master/LIFE_FER/prueba_recre_3_3_3/zepa_canari.shp' not recognised as a supported file format.

10/01/2018 14:31:23  root                 INFO     Starting natcap.invest.recreation.recmodel_client
ERROR 4: `D:\Users\albertonk91\Desktop\UAM master\LIFE_FER\prueba_recre_3_3_3' not recognised as a supported file format.

10/01/2018 14:31:23  root                 INFO     Setting tempfile.tempdir to D:\Users\albertonk91\Desktop\UAM master\LIFE_FER\prueba_recre_3_3_3\tmp
10/01/2018 14:31:23  natcap.invest.recmodel_client INFO     Contacting server, please wait.

LOG 3: Only with one polygon

C:\InVEST_3.3.3_x86\invest-3-x86>.\invest.exe recreation
(<natcap.invest.iui.modelui.ModelUI object at 0x09A44A80>, 'setting super to None')
('lastrun URI:', u'recreation_lastrun_3.3.3.json')
10/01/2018 14:34:35  root                 DEBUG    Loading <module 'natcap.invest.recreation.recmodel_client' from 'C:\INVEST~1.3_X\INVEST~1\natcap\invest\recreation\recmodel_client.pyc'> in frozen environment
10/01/2018 14:34:35  root                 INFO     Logging will be saved to natcap.invest.recreation.recmodel_client-log-2018-10-01--14_34_35.txt
10/01/2018 14:34:35  root                 DEBUG    Loaded the model from natcap.invest.recreation.recmodel_client
10/01/2018 14:34:35  root                 INFO     Executing the loaded model
10/01/2018 14:34:35  root                 INFO     Running InVEST version "3.3.3"
10/01/2018 14:34:35  root                 INFO     Python architecture: ('32bit', 'WindowsPE')
10/01/2018 14:34:35  root                 INFO     Disk space remaining for workspace: 258.56 GB
10/01/2018 14:34:35  root                 INFO     Pointing temporary directory at the workspace at D:\Users\albertonk91\Desktop\UAM master\LIFE_FER\prueba_recre_3_3_3\canari_1
ERROR 4: `D:/Users/albertonk91/Desktop/UAM master/LIFE_FER/prueba_recre_3_3_3/zepa_canar_1.shp' not recognised as a supported file format.

10/01/2018 14:34:35  root                 INFO     Starting natcap.invest.recreation.recmodel_client
ERROR 4: `D:\Users\albertonk91\Desktop\UAM master\LIFE_FER\prueba_recre_3_3_3\canari_1' not recognised as a supported file format.

10/01/2018 14:34:35  root                 INFO     Setting tempfile.tempdir to D:\Users\albertonk91\Desktop\UAM master\LIFE_FER\prueba_recre_3_3_3\canari_1\tmp
10/01/2018 14:34:35  natcap.invest.recmodel_client INFO     Contacting server, please wait.

The error suggests that the problem is with the shp format but it is a normal shp projected in UTM.

Can you help me? It should be easy to solve...

Thanks in advanced

Alberto

Comments

  • Finally, after more than 2 hours, the first LOG gives me this result:

    10/01/2018 14:55:25  root                 ERROR    ---------------------------------------------------
    10/01/2018 14:55:25  root                 ERROR    ---------------------- ERROR ----------------------
    10/01/2018 14:55:25  root                 ERROR    ---------------------------------------------------
    10/01/2018 14:55:25  root                 ERROR    Error: exception found while running natcap.invest.recreation.recmodel_client
    10/01/2018 14:55:25  root                 DEBUG
    10/01/2018 14:55:25  root                 DEBUG    Build details
    10/01/2018 14:55:25  root                 DEBUG    Interpreter
    10/01/2018 14:55:25  root                 DEBUG    Current temp dir: E:\recre_3_3_3\tmp
    10/01/2018 14:55:25  root                 DEBUG    tempfile.tempdir: E:\recre_3_3_3\tmp
    10/01/2018 14:55:25  root                 DEBUG
    10/01/2018 14:55:25  root                 DEBUG    System
    10/01/2018 14:55:25  root                 DEBUG    OS              : Windows-8-6.2.9200
    10/01/2018 14:55:25  root                 DEBUG    Processor architecture: AMD64
    10/01/2018 14:55:25  root                 DEBUG    FS encoding     : mbcs
    10/01/2018 14:55:25  root                 DEBUG    Preferred encoding: cp1252
    10/01/2018 14:55:25  root                 DEBUG
    10/01/2018 14:55:25  root                 DEBUG    Python
    10/01/2018 14:55:25  root                 DEBUG    Version         : 2.7.9
    10/01/2018 14:55:25  root                 DEBUG    Build           : ('default', 'Dec 10 2014 12:24:55')
    10/01/2018 14:55:25  root                 DEBUG    Compiler        : MSC v.1500 32 bit (Intel)
    10/01/2018 14:55:25  root                 DEBUG    Implementation  : CPython
    10/01/2018 14:55:25  root                 DEBUG    Architecture    : 32bit
    10/01/2018 14:55:25  root                 DEBUG    Linkage format  : WindowsPE
    10/01/2018 14:55:25  root                 DEBUG
    10/01/2018 14:55:25  root                 DEBUG    Packages
    10/01/2018 14:55:25  root                 DEBUG    Cython          : ?
    10/01/2018 14:55:25  root                 DEBUG    Numpy           : 1.11.2
    10/01/2018 14:55:25  root                 DEBUG    Scipy           : 0.16.1
    10/01/2018 14:55:25  root                 DEBUG    OSGEO           : 1.11.3
    10/01/2018 14:55:25  root                 DEBUG    Shapely         : 1.5.5
    10/01/2018 14:55:25  root                 DEBUG    InVEST          : 3.3.3
    10/01/2018 14:55:25  root                 DEBUG
    10/01/2018 14:55:25  root                 DEBUG
    10/01/2018 14:55:25  root                 DEBUG    Exception not environment-related
    10/01/2018 14:55:25  root                 DEBUG    Printing traceback
    10/01/2018 14:55:25  root                 DEBUG    Printing traceback
    10/01/2018 14:55:25  root                 ERROR    Exception <type 'exceptions.UnicodeDecodeError'>, 'utf8' codec can't decode byte 0xf3 in position 1299: invalid continuation byte found
    10/01/2018 14:55:25  root                 ERROR    Exiting due to failures
    10/01/2018 14:55:25  root                 INFO     Elapsed time: 2h 5m 50.54s
  • DaveDave Member, Administrator, NatCap Staff
    Hi Alberto,

    I think I'll need to get your shapefiles in order to troubleshoot this. Could you send your data to davefisher@stanford.edu (via attachment, dropbox, etc.)? Also please include the logfile (the .txt file) from one of those runs.

    Thanks,
    Dave
  • DaveDave Member, Administrator, NatCap Staff
    It seems like the errors listed above are resolved by upgrading to InVEST 3.5.
This discussion has been closed.