Error in SDR Model

saletesalete Member
Hi all, I'm a new user of InVEST, i'm trying to use SDR model but when I run the model I received always the same message: The rasters' and vectors' intersection is empty (not all rasters and vectors touch each other). Can you help me please? 
Thanks Regards salete 
Tagged:

Comments

  • swolnyswolny Member, NatCap Staff
    Hi @salete -

    When you're posting about an error, it's really helpful if you include the whole log file (.txt file) that the model produces in your Workspace, that will give us more information to work with.

    It sounds like at least one of your input spatial layers does not overlap with the others. Check to make sure that they are all in the same projected (not geographic) coordinate system, and that they do all overlap. Note that ArcGIS in particular can make them look like they all overlap, even if they're not in the same coordinate system. 

    ~ Stacie


  • saletesalete Member
    Hi stacie, 

    i project all my files, but still not working. could you please take a look, and tell me what is wrong. 

    Thanks a lot 
    Regards 
    salete 
  • swolnyswolny Member, NatCap Staff
    Hi salete -

    Is it possible for you to send me your data? Probably the easiest way to see what's happening. My email address is swolny at stanford.edu

    ~ Stacie
  • swolnyswolny Member, NatCap Staff
    I'm still not quite sure why you are getting the overlap error, but it looked like the model might be having problems with two of your raster inputs, which are in Arc GRID format. I fixed that error by exporting all of your raster inputs to TIFF format. The software usually does accept GRIDs, but I still recommend using TIFF if possible.

    But then another error occurred, because the "lucode" values in Biophysical.csv did not match the raster Values in lc_2015_clip. I changed the lucode values, and the model ran successfully.

    So please try those two things and hopefully they'll work for you too.

    ~ Stacie

  • swolnyswolny Member, NatCap Staff
    Another note: Looking at the results using a Threshold Flow Accumulation of 1000, there are very few streams defined (stream.tif), and those that are defined are in pieces, not continuous streams. This usually means that your DEM needs to have pits filled, and we recommend using the QGIS Wang & Liu tool for best results.

    When there aren't streams defined, you may also get areas of missing data in your results, which I also see. So try working with your DEM to create a good stream network.

    ~ Stacie
Sign In or Register to comment.