error with opening HRA - missing .bat files

Hello all,

I've been using InVEST particularly with the overlap analysis. I'm now trying to run the Habitat Risk Analysis but keep getting errors. I can open other models with InVEST version 3.4.4_x86, but not HRA (neither the preprocessing model or the actual model). I'm using Win10.

The error message I keep getting is that Windows can't find the .bat files invest_hra_preprocessor.bat and invest_hra.bat

Any ideas on how to solve this?

Thanks!

Comments

  • jdouglassjdouglass Administrator, NatCap Staff
    Thanks for letting us know!  I believe we've fixed this issue in a recent development version of InVEST.  Could you try installing InVEST from http://data.naturalcapitalproject.org/invest-releases/3.4.4.post283+h2018c82b7874/InVEST_3.4.4.post283+h2018c82b7874_x86_Setup.exe and see if that fixes the issue?

    Thanks!
  • It does (after crashing the first time I tried opening), but it seems that some parts where I'm supposed to insert a folder directory, it only accepts files paths (e.g., sections calculate risks to habitats/species). In the print screen attached, you can note the difference in the path symbols, indicating it only accpets files instead of folder paths.


    5120 x 1800 - 765K
  • jdouglassjdouglass Administrator, NatCap Staff
    Hm, interesting that it crashed the first time, but worked the second time.  Please do let us know if the crashes persist.

    Thanks for letting us know about the File/Folder inputs in HRA!  Could you try this development build and see if that fixes the issue? Here's the download: http://data.naturalcapitalproject.org/nightly-build/invest-forks/jdouglass/InVEST_3.4.4.post287+h0f8d27aa3bae_x86_Setup.exe
  • Hi,

    it seems to be working now, both HRA preprocessor and HRA models. I'm still getting acquainted with the model, so it might take a couple days of running the model with the database first to check if there's any other issues (hopefully not :) hehe)

    oh, I did get this message when opening both models, but it seems to be working normally despite of that:
    "Runtime warning: selected binding pyqt5 could not be found, using pyqt4"

    thanks!!
  • Errr, actually, after closing InVEST this last time, I can't open it anymore... none of the models. It first said the path was not available with the option to ' correct', delete or close the window. I chose correct it and it now says invest.exe can't be found.
  • dvilanovadvilanova Member
    edited July 31
    The complete message I get is (rough translation, since my computer is set to Portuguese):

    Item "invest.exe" to which this shortcut refers to has been altered or moved.The shortcut will not function correctly.

    Closest correspondence based on size, data and type: C:\Program Files (x86)\Microsoft

    Do you wish to correct/repair the shortcut to this path or do you wish to delete it?

    If I choose ' repair' it says that I have no permission to execute this app on my computer
    Post edited by dvilanova on
  • jdouglassjdouglass Administrator, NatCap Staff
    Yes, the warning message "Runtime warning: selected binding pyqt5 could not be found, using pyqt4" can be safely ignored.

    Hmm, very surprising that InVEST would suddenly not be available!  I've never seen this sort of thing happen before.

    Just to check, the development build I sent you should have installed start menu shortcuts under a folder called something like "InVEST 3.4.4.post287+h0f7d27aa3bae" ... are these the InVEST shortcuts you're trying to launch?  If so, could you double-check that the InVEST development build application is still available in the place you installed it?  The default location for this would be under "C:\InVEST_3.4.4.post287+h0f7d27aa3bae_x86\invest-3-x86\invest.exe".
  • the only invest.exe file that is in this folder is invest.exe.manifest 

    there's also an InVEST icon file in this folder but it says InVEST-2 (.ico ?! it says unknown application)

    I've used InVEST before in this computer many times, but haven't had any issues before (first time trying to run HRA though, also with the most update version and then these beta versions you've been sending)

    thanks!
  • jdouglassjdouglass Administrator, NatCap Staff
    Wow!  So, it sounds like the InVEST application is completely missing!  No wonder the start menu shortcut can't find the application.

    I have no idea why the InVEST application isn't there now (but was before) or why it went missing ... could you try reinstalling the development build from http://data.naturalcapitalproject.org/nightly-build/invest-forks/jdouglass/InVEST_3.4.4.post287+h0f8d27aa3bae_x86_Setup.exe? ; That should put the application back where it's supposed to go.
  • jdouglassjdouglass Administrator, NatCap Staff
    Hey @dvilanova, we coincidentally just had a similar issue come up here int he office.  It turned out that an antivirus program might see the invest.exe application and erroneously quarantine it.  Is it possible that you have an active antivirus program running (other than Windows Defender)?  If so, could you see if the invest.exe application is there in your quarantine, and restore it if so?
  • Hi Douglas!

    Yes, you got this right! My antivirus sent the application invest.exe to quarantine :/ I restored it and seems to be working now. I'll keep you posted if anything else comes up.

    big thanks!

    Daniele
  • Hi Douglas! 

    I'm still having trouble with using Invest on my computer. The antivirus issue (sending files to quarantine, then click to restore it) sometimes work, other (most times) doesn't, and the program shuts down without previous notice (when I'm setting the right directories to run an analysis). Is there a newer version that hasn't been showing this issue? Thanks!
  • jdouglassjdouglass Administrator, NatCap Staff
    Hello!  I haven't seen the issue for some time ... it only ever seems to happen when there's an active antivirus software on people's computer(s).  We do have a new InVEST release out which you're very welcome to try: https://naturalcapitalproject.stanford.edu/invest/

    In the general case, though, the best thing will be to make sure that your antivirus doesn't move the application to quarantine.

    Good luck!
Sign In or Register to comment.