error about the seasonal water yield model in InVEST 3.3.3

I meet a error when I use the InVEST 3.3.3 to analysis the seasonal water yield, that is what shows in the InVEST model. Who can help me to see what error I meet, and tell me how can I solve this problem. Thank you!

Traceback (most recent call last):
  File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\exe\build\invest\out00-PYZ.pyz\natcap.invest.iui.executor", line 620, in runModel
  File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\exe\build\invest\out00-PYZ.pyz\natcap.invest.seasonal_water_yield.seasonal_water_yield", line 163, in execute
  File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\exe\build\invest\out00-PYZ.pyz\natcap.invest.seasonal_water_yield.seasonal_water_yield", line 386, in _execute
  File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\exe\build\invest\out00-PYZ.pyz\natcap.invest.seasonal_water_yield.seasonal_water_yield", line 568, in _calculate_monthly_quick_flow
  File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\exe\build\invest\out00-PYZ.pyz\pygeoprocessing.geoprocessing", line 2389, in vectorize_datasets
  File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\exe\build\invest\out00-PYZ.pyz\natcap.invest.seasonal_water_yield.seasonal_water_yield", line 558, in si_op
RuntimeWarning: divide by zero encountered in divide

06/13/2018 15:31:31  root               ERROR    Exiting due to failures


Comments

  • swolnyswolny Member, NatCap Staff
    Hi @Zigo123 -

    If you can post all of the messages in the log file that the model creates (not just the final error), that will help us understand better what is happening. Thanks!

    Meanwhile, I can suggest a couple of things. First, you're using a relatively old version of InVEST, so I would highly recommend trying the latest version (3.4.4) and see if you still get the error.

    Also, do you have values of 0 (zero) for curve number in your biophysical table? I believe that the model can't handle zero (because you get the 'divide by zero' problem that the error mentions), so try changing those to a value of 1 and see if that helps.

    If neither of these things help, please post the whole log file and we'll figure it out.

    ~ Stacie


  • Thank you very much for your help. When changing the 0 in the biophysical table to a value of 1, the result is successful! However, I also tried it in InVEST 3.4.4 and it can be done without modification. Thank you! So it means that there is no bug of 'divide by zero' problem in the InVEST 3.4.4.
  • swolnyswolny Member, NatCap Staff
    Great, thanks for the update!

    ~ Stacie
This discussion has been closed.