Portfolio Translator

shaedenshaeden Member
Hi Stacie

I trust you are keeping well. My apologies to bother you again. I have managed to successfully run the IPA and generate various output including the html budget report. However, when I proceed to the next step which is to run the portfolio translator, I am unable to load the RIOS work space to which i saved the results obtained from the IPA run.

Please see attached a copy of the status update message shown in the black console window that opens when PORTER is launched. I am not sure what this relates to.

Kind Regards
image

Comments

  • DougDoug Administrator, NatCap Staff
    Hi @shaeden,

    Just an active InVEST User here, but thought I could help,

    It looks like perhaps there is a 'description' column field name missing from the LULC Biophysical Coefficients Table for IPA. 

    Page 73 of the RIOS Users Guide has a list of the column fields it expects:


    It looks like the 'name' of the lulc type should go in that 'description' column. So maybe, 'lulc_0', 'lulc_1', or something 
    easy like that. 

    The RIOS sample data for the biophysical table demonstrates this in the file: RIOS_lulc_biophysical_table_Gura_nutrients.csv

    That sample data can be grabbed here:


    Hope this helps!
  • shaedenshaeden Member
    Hi @Doug

    I have managed to get it to work. I did previously setup the .csv file as specified but for some reason it did not work, I copied my data into the gura_sample data file and renamed it and it seemed to have resolved the issue. Thank you for your assistance in this regard.

    Kind Regards

    Shaeden
  • swolnyswolny Member, NatCap Staff
    Thanks, @Doug, and @Shaeden, I'm glad you got it working.

    ~ Stacie
  • DougDoug Administrator, NatCap Staff
    No problem!
  • shaedenshaeden Member
    Hi @stacie and @doug

    I have been recently working on some different scenarios to compare how using different budget levels in each of the portfolios will influence HES delivery, mainly looking at analyzing the SDR and Water Yield outputs from InVEST.

    When I previously ran the portfolio translator at a specific budget level all worked fine, however since changing the budget level I have run into an error which I can't quite seem to figure out. Please see the attached log file.

    On a similar note, I attempted to analyze the SDR from a previous successful portfolio translator run, I get the following error. Please see attached.

    Kind Regards

    Shaeden 
  • RichRich Administrator, NatCap Staff
    Hi @Shaeden, that SDR error is obscure, but looking at the code I wonder if there might be an issue with your watersheds overlapping an area that doesn't have result pixels in them.

    If you want to share your SDR datastack with me at rpsharp@stanford.edu I'd be happy to take a look and see if I can fix it on my end.

  • shaedenshaeden Member
    Hi please see the link below which includes all the requisite files used during the investment portfolio advisor and portfolio translator simulations. I have also included the log files showing that I was able to successfully run these modules using the following files.


    Thank you for your assistance.

    Regards

    Shaeden
  • shaedenshaeden Member
    Hi 

    If you are unable to access the data from the previous link, please use this one instead 


    Kind Regards 

    Shaeden
  • shaedenshaeden Member
    Hi @Rich. I just wanted to follow up if you have managed to access the data stack and figure out what could be causing the error as described above.

    Kind Regards

    Shaeden
  • RichRich Administrator, NatCap Staff
    Hi @shaeden, I got your datastack, but the directory structure is different than what you posted in your SDR log. I dug around but was unable to find:

    * base_coefficients_All_objectives.csv
    * base_lulc_All_objectives.tif
    * soil_erodibility.tif

    Can you add those to your Dropbox and I can take a look?
  • shaedenshaeden Member
    Hi @Rich My apologies for this. I have been trying to resolve the issue and have created so many different files that I might have mixed these up. I have uploaded a new lot of input files as well as results, which you can access from the link below. I managed to resolve the previous issue I was having. However, I am now running into a new one, which seems to be similar to that which another user experienced i.e I am getting -1 for the sed export, sed reten and usle_tot fields in the watershed shapefile and unrealistic values for sed_export.tif


    Please let me know if there is any further information that you require.

    Kind Regards

    Shaeden
  • RichRich Administrator, NatCap Staff
    Hi @shaeden, it looks like you have hydrological pits in your DEM. This causes the flow accumulation raster to start and stop and in general messes with the hydrological connectivity model of SDR. Can you fill your dem with ArcHydro or SAGA GIS (Wang & Liu algorithm) and give it another run?

    Also, depending on your timing, we're working on a new version of InVEST that automatically does pit filling that'll be out in a couple of months.

  • shaedenshaeden Member
    Hi @Rich

    I have tried various approaches to fill the DEM using ArcHydro and SAGA GIS. After completing this task I checked to see if there were still any sinks present in the newly filled DEM. The results indicated that the DEM was now depression less. However, after using this newly filled DEM in the SDR model I still run into the same problem. Any further suggestions?

    The new version of InVEST will definitely be of great assistance and I would like to be informed of its availability once its released, however I do need to compute these results as soon as possible. Any assistance would be greatly appreciated.

    Kind Regards

    Shaeden
Sign In or Register to comment.