scenario generator - constraints

Hi! I'm using the experimental tool "Scenario Generator" particularly I'm trying to use 'constraints' to reduce the quantity of change in some parts of the landscape. The guidelines report that if the "prot level" has a value of 0 the constraints have full effect and no conversion can take place within the boundary of the constraint while a value of 1 implies that the constraint has no effect. I tried to put any value from 0 to 1 but the model allocates new pixels into constraints' boundary despite it has a lot of place out of boundary to allocate new conversion pixel. 
I formatted the attribute table of the shp as given in sample data ("field named ‘protlevel’ with a value between 0 and 1 where 0 means the layer is fully protected and 1 means the layer is fully open to change") but looking at log file I noticed that at the beginning of the file there is "constraints_field UNKNOWN" and then a warning message "failed to find field UNKNOWN on layer Constraints, skipping".
I attach the log txt file and img of the warning message.
Any idea on this? thanks to everybody in advance
image

Comments

  • jdouglassjdouglass Administrator, NatCap Staff
    Hi @edp, when providing your constraints layer, the model also needs you to specify the constraints field (which should have been loaded in the UI when you provided the constraints vector!).  It's interesting that the constraints field stayed as UNKNOWN.  If you can't change the field to select a different field from the vector, could you send your inputs to jdouglass@stanford.edu so I can take a look?

    Thanks!
    James
  • edpedp Member
    Hi @jdouglass, thank you for the answer!
    I just realized that the InVest version 3.2.0 runs correctly while the last version I'm using (3.4.4) gives me some issues with the "constraints_field" that actually gives me UNKNOWN, having no way to change it.
    I'll send you soon a folder with the data and the screenshots about both InVest's version. 

    Thanks for the availability!
  • mlacayomlacayo Member
    Hi all, this seems to be working in version 3.4.1, but in version 3.4.4 selecting the constraints field from the sample data is no longer working.
  • edpedp Member
    Hi everybody!
    Everything works with 3.4.1 version! I've just finished checking the output map!

    Thank you all!


Sign In or Register to comment.