Error Scenario Generator Rule Based

Hello folks, please I would like to request help regarding this following error in INVEST Scenario Generator Rule Based
"utf8 can't decode byte invalid continuation byte"
All the inputs are ok (with green check)
What is the reason?
How can i fix it?
Thanks in advance 
971 x 601 - 215K
Tagged:

Comments

  • jdouglassjdouglass Administrator, NatCap Staff
    Based on the error, I'd guess that the UI is crashing on a character in the filename that isn't being handled correctly.  Proper internationalization is really tricky!  Could you try the latest version of InVEST and see if this is still an issue?  (download here: https://www.naturalcapitalproject.org/invest/)

    Thanks!
    James
  • Hello again and thank you for your swift answer!
    In the image you can see an updated after following your guideline.
    Any ideia? Do you think is sintax? 
    Thanks! :) 
    785 x 680 - 205K
  • jdouglassjdouglass Administrator, NatCap Staff
    From the text of the error message, it looks like your CSV table "Mau2.csv" is missing a required column labelled "id".  In case it's helpful, the structures of the scenario generator's inputs are documented in the User's Guide chapter: http://data.naturalcapitalproject.org/nightly-build/invest-users-guide/html/scenario_generator.html#data-needs

    Hope this helps!
  • Hey jdouglass, thank you for your support and collaboration!
    After some experiments, I am facing a new error....

    698 x 522 - 124K
  • jdouglassjdouglass Administrator, NatCap Staff
    Yes, this error is a little cryptic.  Is it possible that your suitability table is missing a code of 2?  If that doesn't look right, could you attach your whole logfile to this thread so I can take a look?
  • Indeed, what an error!
    Here it is!
    Thanks! ;) 
  • jdouglassjdouglass Administrator, NatCap Staff
    Thanks for attaching your logfile.  Is it possible that your suitability table is missing a code of 2?
  • Hey again!
    Thanks so much for your help!
    In the end I did cross the issues that were going on!
    I am not exactly sure if it was indeed the missing code, but after trying hard and make some changes I could make it trough!
    I guess your support was fundamental!

  • jdouglassjdouglass Administrator, NatCap Staff
    Glad to hear that the tool is running successfully!
This discussion has been closed.