NatCap Recreation/Visitation hole @ international dateline error

Hi again Dave,

So- did I think as you suggested- pre-gridded my AOI and then broke it up into chunks and fed them though Recreation invest. 
[It's a pretty big AOI so the shapefile size limitation was a factor possibly as well (why not raster, Sir?) but not the real reason I write.] 

It worked pretty well except there's a big hole (aka all cells in this input strip return 0) for what seems like a really large chunk around the international date line of a couple hundred km. (screenshot of output attached)

The actual AOI is projected to have a central meridian  @ 180, so that should not be the problem. Have also tried further breaking up this strip and running it through again with no luck.

Wondering if there is any way to get this data?


(Thoughts of troubleshooting: Does the Recreation data go all the way to 180? Is this something that could be resolved by the input data on the program side projected to something else, say cylindrical equal area central meridian 180?)

OK. Thank you for your help and I look forward to hearing from you.

image

Comments

  • Hi Abby,
    I am not a developer on this model, but this reminds me of a discussion thread for the wind energy model https://forums.naturalcapitalproject.org/index.php?p=/discussion/777/wind-model-run-error#latest

    Have you tried Malin's approach of delineating two AOI that stop just short of 180 on each side to get around this? Kind of clunky, but if it works you may only lose a few observations. It is worth noting that this could introduce problems if you are using the regression options in the rec model, though the solution for that might be easier than the fix for the original problem. 

    Sorry for the slow response time on this, Dave is out of the office currently. 

    Regards,
    Rob
  • Thank you Rob! I will try that. 

    No need to apologize on your end. Just realized I had posted on a closed issue- sorry for the confusion.

    This makes sense as it was oddly contained to the AOI and guess the seam throws an error. Thank you!
    Too bad we can't get InVest to reproject.... but this works- cheers.

    -A
  • So, chopped and re-chopped the pre-gridded AOI sliver but getting consistently an OSError Errno 12 'Cannot allocate memory'. 
    Does not seem to refer to the memory on my computer I don't think-much drive space & tried diff. ones. Putting in chunks smaller than was proceced in the past.

    Any thoughts?
    Help most appreciated.
  • RichRich Administrator, NatCap Staff
    Hi Abby, it looks like the recreation server was stuck in a bad place. I reset it and it works on my end now. Would you be willing to try it again?
Sign In or Register to comment.