Recreation Model Error

Hello,

I've been using the recreation model for several provinces in Canada, and have been able to do so successfully in the past - however, recently I have encountered this error in each attempt. Would someone be able to point out for me what is going wrong, and how I can fix it?

Below is the error log. 

Thanks!

07/18/2017 10:54:02 root ERROR ---------------------------------------------------

07/18/2017 10:54:02 root ERROR ---------------------- ERROR ----------------------

07/18/2017 10:54:02 root ERROR ---------------------------------------------------

07/18/2017 10:54:02 root ERROR Error: exception found while running natcap.invest.recreation.recmodel_client

07/18/2017 10:54:02 root DEBUG

07/18/2017 10:54:02 root DEBUG Build details

07/18/2017 10:54:02 root DEBUG Interpreter

07/18/2017 10:54:02 root DEBUG Current temp dir: C:\Users\Marcus Becker\Documents\InVEST_Recreation\RD_Test\tmp

07/18/2017 10:54:02 root DEBUG tempfile.tempdir: C:\Users\Marcus Becker\Documents\InVEST_Recreation\RD_Test\tmp

07/18/2017 10:54:02 root DEBUG

07/18/2017 10:54:02 root DEBUG System

07/18/2017 10:54:02 root DEBUG OS : Windows-7-6.1.7601-SP1

07/18/2017 10:54:02 root DEBUG Processor architecture: AMD64

07/18/2017 10:54:02 root DEBUG FS encoding : mbcs

07/18/2017 10:54:02 root DEBUG Preferred encoding: cp1252

07/18/2017 10:54:02 root DEBUG

07/18/2017 10:54:02 root DEBUG Python

07/18/2017 10:54:02 root DEBUG Version : 2.7.9

07/18/2017 10:54:02 root DEBUG Build : ('default', 'Dec 10 2014 12:24:55')

07/18/2017 10:54:02 root DEBUG Compiler : MSC v.1500 32 bit (Intel)

07/18/2017 10:54:02 root DEBUG Implementation : CPython

07/18/2017 10:54:02 root DEBUG Architecture : 32bit

07/18/2017 10:54:02 root DEBUG Linkage format : WindowsPE

07/18/2017 10:54:02 root DEBUG

07/18/2017 10:54:02 root DEBUG Packages

07/18/2017 10:54:02 root DEBUG Cython : ?

07/18/2017 10:54:02 root DEBUG Numpy : 1.11.2

07/18/2017 10:54:02 root DEBUG Scipy : 0.16.1

07/18/2017 10:54:02 root DEBUG OSGEO : 1.11.3

07/18/2017 10:54:02 root DEBUG Shapely : 1.5.5

07/18/2017 10:54:02 root DEBUG InVEST : 3.3.3

07/18/2017 10:54:02 root DEBUG

07/18/2017 10:54:02 root DEBUG

07/18/2017 10:54:02 root DEBUG error <type 'exceptions.OSError'> number 12

07/18/2017 10:54:02 root DEBUG Error message: [Errno 12] Cannot allocate memory

07/18/2017 10:54:02 root DEBUG Exception not disk-space related

07/18/2017 10:54:02 root DEBUG Printing traceback

Traceback (most recent call last):

File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\exe\build\invest\out00-PYZ.pyz\natcap.invest.iui.executor", line 620, in runModel

File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\exe\build\invest\out00-PYZ.pyz\natcap.invest.recreation.recmodel_client", line 229, in execute

File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\exe\build\invest\out00-PYZ.pyz\Pyro4.core", line 178, in __call__

File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\exe\build\invest\out00-PYZ.pyz\Pyro4.core", line 450, in _pyroInvoke

OSError: [Errno 12] Cannot allocate memory



07/18/2017 10:54:02 root ERROR Exiting due to failures

Comments

  • RichRich Administrator, NatCap Staff
    Hi, we sometimes see that error when the area of interest is gridded especially finely.  If you are gridding your AOI, could you try a much larger grid size to see if that's the issue?  Or if your AOI is especially large (large as the continential united states for example), could you try a smaller section and see if that resolves your issue?
  • mabeckermabecker Member
    Hi Rich, thanks for the reply. 

    I wasn't gridding the AOI, rather using a Shapefile with >1,000 polygon features (most of which are quite small). I've tried again with a subset of the features, but still receive an error, the most recent of which is:

    OSError [Errno 28] No space left on device

    Have you encountered this error as well? I have a large amount of space left on my computer (>100GB), so not sure how to address this. 

    Thanks!
  • RichRich Administrator, NatCap Staff
    Hi, the error was that the recreation server disk filled up.  Totally my fault.  It's back up and running on my end now.  Can you try again and post here if you run into any more issues?
  • Hi Rich,
    I seem to have just run into this issue as well, and I'm not gridding my AOI yet, just the base run
    OSError: [Errno 28] No space left on device
  • jdouglassjdouglass Administrator, NatCap Staff
    hi @michael_weinerman, could you try running the rec model again?  The server was down for a couple of days, but should be back online now.
  • DaveDave Member, NatCap Staff
    I think Michael confirmed on another thread that his Rec run succeeded. So marking this one resolved, for whatever that's worth!
This discussion has been closed.