InVEST shortcut does not appear on start menu

jarotjarot Member
edited June 2 in MOOC
Hi all,

I'm new to InVEST and still following the MOOC NCP102.
When I successfully install InVEST ver 3.3.3 in my computer (Win 10) I didn't found InVEST shortcut on my start menu as shown on the video module 3.

When I look on the installed folder (C:\InVEST_3.3.3_x86\invest-3-x86) I found "invest.exe" and when I clicked it, it opens a command window and asking for the model that I wanted to use. But when I type the model name and click enter, the window closed and nothing happens.


Thank you

Jarot
386 x 588 - 56K
1125 x 912 - 91K
Post edited by jarot on
Tagged:

Comments

  • RichRich Administrator, NatCap Staff
    Hi, not sure why things aren't showing up in the start menu, but I have a couple of ideas.

    A throwaway idea, I feel like in the past I've had things show up in the start menu after a reboot of windows, even if I just installed them.  Might try that if it's easy.

    Next, if you scroll down a little past your invest.exe you'll see files named things like `invest_carbon` and `invest_fisheries`.  You should be able to double click on those to launch a UI -- its what the start menu items link to anyway.

    And last thing, if you go to your C:\InVEST_3_3_3_x86 directory, there will be a file in there called `install_log.txt`.  Any chance you could post that here?  That might show us something that went wrong when the start menu items were being added.
  • jarotjarot Member
    Hi Rich,

    Thank you for the solution. Direct double click on the models name is working.

    You can find the 'install_log.txt' file in the attachment, and in the log file looks like there are errors in creating folders inside windows start menu folder.

    thank you
  • RichRich Administrator, NatCap Staff
    Thanks for the log.  And yes, looks like that's why things weren't showing up in your start menu.  If you're happy with this, then we can leave it be.  I'll otherwise chat with James when he gets back from vacation. I wonder if it is a windows permissions issue we can deal with for the next version.
  • jdouglassjdouglass Administrator, NatCap Staff
    Very interesting, and thanks for the log!  Could you try this dev build and see if it fixes the issue?  Here's the download link: http://data.naturalcapitalproject.org/nightly-build/invest-forks/jdouglass/InVEST_jdouglass3.3.3.post78+nd5f61c31e76f_x86_Setup.exe
  • jarotjarot Member
    Hi Jdouglass,

    Thank you for the dev build, it works, and the shortcut shows on the start menu now.


    thank you
  • jdouglassjdouglass Administrator, NatCap Staff
    Awesome, thanks for the update!  I'll add this fix to the queue for the next release of InVEST.
This discussion has been closed.