This forum is shutting down! Please post new discussions at community.naturalcapitalproject.org

Error using invest water yield model

bloomibloomi Member
edited May 2017 in General
Hi, I am trying to use INVEST to model water yield, I am a new user of the software and as soon as I produced the data, run the project, boom, here comes the error. I cannot figure why this happened after really hard trying....

The error says:"

Traceback (most recent call last):
  File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\exe\build\invest\out00-PYZ.pyz\natcap.invest.iui.executor", line 620, in runModel
  File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\exe\build\invest\out00-PYZ.pyz\natcap.invest.hydropower.hydropower_water_yield", line 192, in execute
  File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\exe\build\invest\out00-PYZ.pyz\pygeoprocessing.geoprocessing", line 1602, in reclassify_dataset_uri
  File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\exe\build\invest\out00-PYZ.pyz\pygeoprocessing.geoprocessing", line 2389, in vectorize_datasets
  File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\exe\build\invest\out00-PYZ.pyz\pygeoprocessing.geoprocessing", line 1592, in map_dataset_to_value
ValueError: There was not a value for at least the following codes [31 34 35 36 37 38 41 43 45 47 48 50 63] for this file D:\data\Yzblueprint\invest\workspace\tmp\tmpux1hxl.
Nodata value is: 255
"

Please see the attached file for details. Thanks you all for the help!!!!!!!!
Post edited by bloomi on

Comments

  • swolnyswolny Member, NatCap Staff
    Hi @bloomi -

    Is it possible that you have all of those codes [31...63] in your landuse raster, but not in your biophysical coefficient table? If they're in your landuse raster, they need to be in the coefficient table too.

    I'm also wondering about what format your input rasters use. They don't have .tif or .img extensions, and don't seem to point to the .adf files of ArcGIS GRID files, so what format are you using?

    ~ Stacie
Sign In or Register to comment.