This forum is shutting down! Please post new discussions at

NDR Crash

Hi Rich,

afraid it's me again.  This time the problem is with NDR crashing for a
specific watershed. I ran the DEM through the Fill tool in ArcHydro,
and t
he data for this particular watershed comes from the same data source(s) as the other watersheds.

have had no problems with running NDR on the other watersheds, so I'm
confused as to why the model crashes for this particular watershed. I've
read through some other postings in the NDR forums and it sounds like
there may be something glitchy with this particular module, might that
be the case here? Or am I just missing something.  

Here's a link to my Data Stack and log file.

Thanks so much,


  • RichRich Administrator, NatCap Staff
    Hi Natalie, I thought I could address this quickly... I'm able to recreate that memory error on my end, but I'm not certain the cause.  The rasters are well below sizes that we normally associate with a memory error so it must be something more unusual.  This might take me a little bit.  I'll get back to you when I can.
  • RichRich Administrator, NatCap Staff
    Hi Again Natalie, we figured out the error; it was a tricky memory leak in a library that PyGeoprocessing uses, but it'll take some work to get that patch into InVEST.  Still a high priority and we're working along.
  • RichRich Administrator, NatCap Staff
    FYI, we were finally able to build a version of InVEST built that fixes the NDR memory error issue for your data:
  • Wow Rich, I can't thank you enough for this new version.  It actually worked across the entire Midwest extent! The SDR results look as they should upon first inspection, and there are no gaps. I will be testing the NDR in the next week.

    Thank you a million times over, you have saved me many hours of having to run sub-watershed simulations.

  • RichRich Administrator, NatCap Staff
    Ha amazing.  You're very welcome.  But please don't celebrate too early!  See how NDR goes and post back again when it doesn't work okay?
Sign In or Register to comment.