Creating subwatershed shapefile for Sediment delivery ratio model

i have got error in creating subwatershed shapefile for SDR model..the shapefile i have created by using arcgis archydro tool doesnt has swat_ id field..how can i add this field to the shapefile....
thank you......

Comments

  • swolnyswolny Member, NatCap Staff
    Hi @dianasandamali91 -

    You add a field to a shapefile by editing the shapefile's attribute table in the GIS. This ArcGIS help document explains how.

    ~ Stacie

  • I  add the field of wat_id but the model rejected the shapefile.The previous error was occurred again.I attached my file and output error of the model submission.
    thank u
  • swolnyswolny Member, NatCap Staff
    edited January 2017
    I don't see the shapefile or the error files - would you please re-upload?

    And please clarify - are you using ArcHydro directly in ArcGIS, or are you using one of our helper scripts? When you get the error, is the error from ArcHydro? The helper script? Or the SDR model?

    ~ Stacie
    Post edited by swolny on
  • PerrinePerrine Moderator, NatCap Staff
    Quick note: the field name should be 'ws_id', not 'wat_id' (if that's what you were suggesting)
  • Thank you very much.. I add the right field ..and submitted for the model..then the model run and this input error occure..I have attached to this ..

    01/26/2017 18:17:00 root DEBUG
    Loading <module 'natcap.invest.sdr' from
    'C:\INVEST~1.2_X\INVEST~1\natcap\invest\sdr.pyc'> in frozen environment

    Arguments:

    biophysical_table_path
    C:/Users/Sandamali/Desktop/invest model/LULS.csv

    dem_path C:/Users/Sandamali/Desktop/invest
    model/DEM.tif

    drainage_path

    erodibility_path
    C:/Users/Sandamali/Desktop/invest model/r factor.tif

    erosivity_path
    C:/Users/Sandamali/Desktop/invest model/r factor.tif

    ic_0_param 0.5

    k_param 2

    lulc_path
    C:/Users/Sandamali/Desktop/invest model/LULS map.tif

    sdr_max 0.8

    threshold_flow_accumulation
    1000

    watersheds_path
    C:/Users/Sandamali/Desktop/invest/subwat/subwat.shp

    workspace_dir
    C:\Users\Sandamali/Documents/sedimentation_workspace

     

     

    01/26/2017
    18:17:00 root INFO Logging will be saved to
    natcap.invest.sdr-log-2017-01-26--18_17_00.txt

    01/26/2017
    18:17:00 root DEBUG Loaded the model from natcap.invest.sdr

    01/26/2017
    18:17:00 root INFO Executing the loaded model

    01/26/2017
    18:17:00 root INFO Running InVEST version "3.3.2"

    01/26/2017
    18:17:00 root INFO Python architecture: ('32bit', 'WindowsPE')

    01/26/2017
    18:17:00 root INFO Disk space remaining for workspace: 52.87 GB

    01/26/2017
    18:17:00 root INFO Pointing temporary directory at the workspace at
    C:\Users\Sandamali/Documents/sedimentation_workspace

    01/26/2017
    18:17:01 root INFO Updating
    os.environ["TMP"]=C:\Users\SANDAM~1\AppData\Local\Temp to
    C:\Users\Sandamali/Documents/sedimentation_workspace

    01/26/2017
    18:17:01 root INFO Updating
    os.environ["TEMP"]=C:\Users\SANDAM~1\AppData\Local\Temp to
    C:\Users\Sandamali/Documents/sedimentation_workspace

    01/26/2017
    18:17:01 root INFO Setting
    os.environ["TMPDIR"]=C:\Users\Sandamali/Documents/sedimentation_workspace

    01/26/2017
    18:17:01 root INFO Setting tempfile.tempdir to C:\Users\Sandamali/Documents/sedimentation_workspace\tmp

    01/26/2017
    18:17:01 root INFO Starting natcap.invest.sdr

    01/26/2017
    18:17:01 root ERROR ---------------------------------------------------

    01/26/2017
    18:17:01 root ERROR ---------------------- ERROR ----------------------

    01/26/2017
    18:17:01 root ERROR ---------------------------------------------------

    01/26/2017
    18:17:01 root ERROR Error: exception found while running natcap.invest.sdr

    01/26/2017
    18:17:01 natcap.invest.iui._log_model WARNING an exception encountered when
    logging [Errno socket error] [Errno 11001] getaddrinfo failed

    01/26/2017
    18:17:01 root DEBUG

    01/26/2017
    18:17:01 root DEBUG Build details

    01/26/2017
    18:17:01 root DEBUG Interpreter

    01/26/2017
    18:17:01 root DEBUG Current temp dir:
    C:\Users\Sandamali/Documents/sedimentation_workspace\tmp

    01/26/2017
    18:17:01 root DEBUG tempfile.tempdir:
    C:\Users\Sandamali/Documents/sedimentation_workspace\tmp

    01/26/2017
    18:17:01 root DEBUG

    01/26/2017
    18:17:01 root DEBUG System

    01/26/2017
    18:17:01 root DEBUG OS : Windows-8-6.2.9200

    01/26/2017
    18:17:01 root DEBUG Processor architecture: AMD64

    01/26/2017
    18:17:01 root DEBUG FS encoding : mbcs

    01/26/2017
    18:17:01 root DEBUG Preferred encoding: cp1252

    01/26/2017
    18:17:01 root DEBUG

    01/26/2017
    18:17:01 root DEBUG Python

    01/26/2017
    18:17:01 root DEBUG Version : 2.7.9

    01/26/2017
    18:17:01 root DEBUG Build : ('default', 'Dec 10 2014 12:24:55')

    01/26/2017
    18:17:01 root DEBUG Compiler : MSC v.1500 32 bit (Intel)

    01/26/2017
    18:17:01 root DEBUG Implementation : CPython

    01/26/2017
    18:17:01 root DEBUG Architecture : 32bit

    01/26/2017
    18:17:01 root DEBUG Linkage format : WindowsPE

    01/26/2017
    18:17:01 root DEBUG

    01/26/2017
    18:17:01 root DEBUG Packages

    01/26/2017
    18:17:01 root DEBUG Cython : ?

    01/26/2017
    18:17:01 root DEBUG Numpy : 1.11.2rc1

    01/26/2017
    18:17:01 root DEBUG Scipy : 0.16.1

    01/26/2017
    18:17:01 root DEBUG OSGEO : 1.11.3

    01/26/2017
    18:17:01 root DEBUG Shapely : 1.5.5

    01/26/2017
    18:17:01 root DEBUG InVEST : 3.3.2

    01/26/2017
    18:17:01 root DEBUG

    01/26/2017
    18:17:01 root DEBUG

    01/26/2017
    18:17:01 root DEBUG Exception not environment-related

    01/26/2017
    18:17:01 root DEBUG Printing traceback

    Traceback (most
    recent call last):

    File
    "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\exe\build\invest\out00-PYZ.pyz\natcap.invest.iui.executor",
    line 560, in runModel

    File
    "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\exe\build\invest\out00-PYZ.pyz\natcap.invest.sdr",
    line 159, in execute

    File
    "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\exe\build\invest\out00-PYZ.pyz\pygeoprocessing.geoprocessing",
    line 2007, in align_dataset_list

    File
    "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\exe\build\invest\out00-PYZ.pyz\pygeoprocessing.geoprocessing",
    line 1758, in assert_datasets_in_same_projection

    DatasetUnprojected:
    These datasets are unprojected set(['C:/Users/Sandamali/Desktop/invest model/r
    factor.tif', 'C:/Users/Sandamali/Desktop/invest model/DEM.tif',
    'C:/Users/Sandamali/Desktop/invest model/LULS map.tif'])

     

     

    01/26/2017
    18:17:01 root ERROR Exiting due to failures

    01/26/2017
    18:17:01 natcap.invest.iui.executor._log_exit_status WARNING an exception
    encountered when _log_exit_status [Errno socket error] [Errno 11001]
    getaddrinfo failed

     

  • swolnyswolny Member, NatCap Staff
    If you look at the very end of this log output, you'll see this:

    DatasetUnprojected:
    These datasets are unprojected set(['C:/Users/Sandamali/Desktop/invest model/r
    factor.tif', 'C:/Users/Sandamali/Desktop/invest model/DEM.tif',
    'C:/Users/Sandamali/Desktop/invest model/LULS map.tif'])


    So the model is giving this error because it thinks that the input layers DEM.tif and LULS map.tif are not in a projected coordinate system. 

    All inputs to the models need to be in the same projected coordinate system. So look at your other inputs, and match the coordinate system of the DEM and LULS map to the same one used in your other layers. Then try running the model again.

    ~ Stacie
  • THANK you. i have already reproject all layers to same coordinate system.but prevoius error ..
    Initializing...

    01/28/2017 13:37:12 root DEBUG Loading <module 'natcap.invest.sdr' from 'C:\INVEST~1.2_X\INVEST~1\natcap\invest\sdr.pyc'> in frozen environment

    Arguments:

    biophysical_table_path C:/Users/Sandamali/Desktop/investnew data/LULS.csv

    dem_path C:/Users/Sandamali/Desktop/investnew data/DEM.tif

    drainage_path

    erodibility_path C:/Users/Sandamali/Desktop/investnew data/k factor.tif

    erosivity_path C:/Users/Sandamali/Desktop/investnew data/r factor.tif

    ic_0_param 0.5

    k_param 2

    lulc_path C:/Users/Sandamali/Desktop/investnew data/luls.tif

    sdr_max 1

    threshold_flow_accumulation 1000

    watersheds_path C:/Users/Sandamali/Desktop/investnew data/subwat/subwat.shp

    workspace_dir C:\Users\Sandamali/Documents/sedimentation_workspace



    01/28/2017 13:37:12 root INFO Logging will be saved to natcap.invest.sdr-log-2017-01-28--13_37_12.txt

    01/28/2017 13:37:12 root DEBUG Loaded the model from natcap.invest.sdr

    01/28/2017 13:37:12 root INFO Executing the loaded model

    01/28/2017 13:37:12 root INFO Running InVEST version "3.3.2"

    01/28/2017 13:37:12 root INFO Python architecture: ('32bit', 'WindowsPE')

    01/28/2017 13:37:12 root INFO Disk space remaining for workspace: 52.4 GB

    01/28/2017 13:37:12 root INFO Pointing temporary directory at the workspace at C:\Users\Sandamali/Documents/sedimentation_workspace

    01/28/2017 13:37:12 root INFO Updating os.environ["TMP"]=C:\Users\SANDAM~1\AppData\Local\Temp to C:\Users\Sandamali/Documents/sedimentation_workspace

    01/28/2017 13:37:12 root INFO Updating os.environ["TEMP"]=C:\Users\SANDAM~1\AppData\Local\Temp to C:\Users\Sandamali/Documents/sedimentation_workspace

    01/28/2017 13:37:12 root INFO Setting os.environ["TMPDIR"]=C:\Users\Sandamali/Documents/sedimentation_workspace

    01/28/2017 13:37:12 root INFO Setting tempfile.tempdir to C:\Users\Sandamali/Documents/sedimentation_workspace\tmp

    01/28/2017 13:37:12 root INFO Starting natcap.invest.sdr

    01/28/2017 13:37:12 root ERROR ---------------------------------------------------

    01/28/2017 13:37:12 root ERROR ---------------------- ERROR ----------------------

    01/28/2017 13:37:12 root ERROR ---------------------------------------------------

    01/28/2017 13:37:12 root ERROR Error: exception found while running natcap.invest.sdr

    01/28/2017 13:37:12 root DEBUG

    01/28/2017 13:37:12 root DEBUG Build details

    01/28/2017 13:37:12 root DEBUG Interpreter

    01/28/2017 13:37:12 root DEBUG Current temp dir: C:\Users\Sandamali/Documents/sedimentation_workspace\tmp

    01/28/2017 13:37:12 root DEBUG tempfile.tempdir: C:\Users\Sandamali/Documents/sedimentation_workspace\tmp

    01/28/2017 13:37:12 root DEBUG

    01/28/2017 13:37:12 root DEBUG System

    01/28/2017 13:37:12 root DEBUG OS : Windows-8-6.2.9200

    01/28/2017 13:37:12 root DEBUG Processor architecture: AMD64

    01/28/2017 13:37:12 root DEBUG FS encoding : mbcs

    01/28/2017 13:37:12 root DEBUG Preferred encoding: cp1252

    01/28/2017 13:37:12 root DEBUG

    01/28/2017 13:37:12 root DEBUG Python

    01/28/2017 13:37:12 root DEBUG Version : 2.7.9

    01/28/2017 13:37:12 root DEBUG Build : ('default', 'Dec 10 2014 12:24:55')

    01/28/2017 13:37:12 root DEBUG Compiler : MSC v.1500 32 bit (Intel)

    01/28/2017 13:37:12 root DEBUG Implementation : CPython

    01/28/2017 13:37:12 root DEBUG Architecture : 32bit

    01/28/2017 13:37:12 root DEBUG Linkage format : WindowsPE

    01/28/2017 13:37:12 root DEBUG

    01/28/2017 13:37:12 root DEBUG Packages

    01/28/2017 13:37:12 root DEBUG Cython : ?

    01/28/2017 13:37:12 root DEBUG Numpy : 1.11.2rc1

    01/28/2017 13:37:12 root DEBUG Scipy : 0.16.1

    01/28/2017 13:37:12 root DEBUG OSGEO : 1.11.3

    01/28/2017 13:37:12 root DEBUG Shapely : 1.5.5

    01/28/2017 13:37:12 root DEBUG InVEST : 3.3.2

    01/28/2017 13:37:12 root DEBUG

    01/28/2017 13:37:12 root DEBUG

    01/28/2017 13:37:12 root DEBUG Exception not environment-related

    01/28/2017 13:37:12 root DEBUG Printing traceback

    Traceback (most recent call last):

    File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\exe\build\invest\out00-PYZ.pyz\natcap.invest.iui.executor", line 560, in runModel

    File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\exe\build\invest\out00-PYZ.pyz\natcap.invest.sdr", line 159, in execute

    File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\exe\build\invest\out00-PYZ.pyz\pygeoprocessing.geoprocessing", line 2007, in align_dataset_list

    File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\exe\build\invest\out00-PYZ.pyz\pygeoprocessing.geoprocessing", line 1758, in assert_datasets_in_same_projection

    DatasetUnprojected: These datasets are unprojected set(['C:/Users/Sandamali/Desktop/investnew data/luls.tif', 'C:/Users/Sandamali/Desktop/investnew data/DEM.tif', 'C:/Users/Sandamali/Desktop/investnew data/k factor.tif', 'C:/Users/Sandamali/Desktop/investnew data/r factor.tif'])



    01/28/2017 13:37:12 root ERROR Exiting due to failures

    I cant imagine what is the problem..

  • swolnyswolny Member, NatCap Staff
    If they are all projected, I don't know what the problem is either. Can you send me your input layers and I'll take a look? swolny at stanford.edu.

    ~ Stacie

  • k.k thank u the file was too big . cannot upload. how can i upload the files?
  • k.k thank u.but the file was too big. How can i upload this files ?
  • these are my files can u help me?
  • RichRich Administrator, NatCap Staff
    Ahh, sorry, these just ArcGIS layer files.  Can you archive the source rasters directly?

    If they're too big you can use a service like dropbox or google drive to share.
  • k.k thanks very much.i sent via google drive.
  • edited February 2017
    thanks your prevoius advices.Now i get this error .can u help me,

    Post edited by dianasandamali91 on
  • edited February 2017
    thanks for prevoius advices.Now i have another eror please help me. the model gets "u 255" error.can i help u to resolve this


    Post edited by dianasandamali91 on
  • Traceback (most recent call last):

    File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\exe\build\invest\out00-PYZ.pyz\natcap.invest.iui.executor", line 560, in runModel

    File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\exe\build\invest\out00-PYZ.pyz\natcap.invest.sdr", line 201, in execute

    File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\exe\build\invest\out00-PYZ.pyz\natcap.invest.sdr", line 554, in _calculate_w

    File "C:\Users\natcap-servers\jenkins-home\workspace\natcap.invest\label\GCE-windows-1\exe\build\invest\out00-PYZ.pyz\pygeoprocessing.geoprocessing", line 1599, in reclassify_dataset_uri

    KeyError: u'255'



    02/05/2017 08:16:09 root ERROR Exiting due to failures

  • edited February 2017


    Post edited by dianasandamali91 on
  • swolnyswolny Member, NatCap Staff
    Would you please post the whole log file (not just the final error), like you did before? That will help us understand where it's giving this error. Thanks!

    ~ Stacie

  • RichRich Administrator, NatCap Staff
    Also from looking at the backtrace, I'd guess that there's a value in your landcover map that's 255, that's not equal to your nodata value of the landcover map AND doesn't have a corresponding entry in your biophysical table.

    There's also an old bug related to unsigned vs. signed byte landcover map values that we've fixed in recent versions of InVEST, so just check to make sure you're using at least InVEST 3.3.2.
  • thank u for advices.I could run the model successfully.but the results i got are not realistic and big values.these are the statistics of my model results. sediment retentn mean = 411148.40493186  sedimnt export =14645.286491257 and soil loss=114782.43742599 Do these values become realistic values.My erosivity map values are range from 480 to 658 erodibility =0.22  c and p factors range from 0 to 1 and dem range from 30 to 1280.
  • RichRich Administrator, NatCap Staff
    Oh boy this is timely, we just fixed a bug in SDR that might be causing your high values.  Do you want to try out this development version of InVEST that has the patched SDR isssue in it?  http://data.naturalcapitalproject.org/invest-releases/3.3.2.post68+n40a0e5167aa6

    I suspect this might be the source of your large export values.
  • thank u.I used the developed version you mentioned.The above data cant change.how i calculate the out put data as the unit of t/ha/yr
  • swolnyswolny Member, NatCap Staff
    edited February 2017
    If you want to calculate tons/ha/year per pixel, just divide sed_export.tif by the area of each pixel, converted to hectares. To calculate the total sediment export per sub-watershed, divide the sed_export value in watershed_output_sdr.shp by the area of each (sub-)watershed, again, converted to hectares, since the pixel size is usually given in meters.

    ~ Stacie
    Post edited by swolny on
  • edited February 2017
    thank u very much for guiding me ...
    Post edited by dianasandamali91 on
  • I have another problem the model says

    Warning 1: Value 755750468.0591774 of field sed_retent of
    feature 0 not successfully written. Possibly due to too larger number with
    respect to field width

    Warning 1: Value 144431739.84143066 of field usle_tot of
    feature 0 not successfully written. Possibly due to too larger number with
    respect to field width

    Warning 1: Value 1435984635.3195658 of field sed_retent of
    feature 1 not successfully written. Possibly due to too larger number with
    respect to field width

    Warning 1: Value 143182833.27714658 of field usle_tot of
    feature 1 not successfully written. Possibly due to too larger number with
    respect to field width

    Warning 1: Value 3148698493.9491119 of field sed_retent of
    feature 2 not successfully written. Possibly due to too larger number with
    respect to field width

    Warning 1: Value 289549915.02430946 of field usle_tot of
    feature 2 not successfully written. Possibly due to too larger number with
    respect to field width

    Warning 1: Value 2678529798.4764843 of field sed_retent of
    feature 3 not successfully written. Possibly due to too larger number with
    respect to field width

    Warning 1: Value 300290423.69995362 of field sed_export of
    feature 3 not successfully written. Possibly due to too larger number with
    respect to field width

    Warning 1: Value 2827411311.1402125 of field usle_tot of
    feature 3 not successfully written. Possibly due to too larger number with
    respect to field width

    Warning 1: Value 2081528922.2278633 of field sed_retent of
    feature 4 not successfully written. Possibly due to too larger number with
    respect to field width

    Warning 1: Value 612197884.96737492 of field usle_tot of
    feature 4 not successfully written. Possibly due to too larger number with
    respect to field width

    Warning 1: Value 570778610.0774231 of field sed_retent of
    feature 6 not successfully written. Possibly due to too larger number with
    respect to field width

    02/16/2017 07:28:37 
    natcap.invest.sdr    WARNING  Can't remove temporary file:
    C:\Users\Sandamali/Documents/sedimentation_workspace\aligned_drainage.tif

    Original Exception:

    [Error 2] The system cannot find the file specified: u'C:\\Users\\Sandamali/Documents/sedimentation_workspace\\aligned_drainage.tif'

    02/16/2017 07:28:37 
    natcap.invest.sdr    WARNING  Can't remove temporary file:
    C:\Users\Sandamali/Documents/sedimentation_workspace\aligned_watersheds_path.tif

    Original Exception:

    [Error 2] The system cannot find the file specified:
    u'C:\\Users\\Sandamali/Documents/sedimentation_workspace\\aligned_watersheds_path.tif'

    02/16/2017 07:28:37 
    root                 INFO     Opening file explorer to workspace
    directory

    02/16/2017 07:28:37 
    natcap.invest.iui.executor._log_exit_status WARNING  an exception encountered when
    _log_exit_status [Errno socket error] [Errno 11001] getaddrinfo failed

    Can i help me to resolve this problem.

  • RichRich Administrator, NatCap Staff
    Hi @dianasandamali91,

    There are a few issues in that log, none of them should affect your result.  The first one are the messages that look like this:

    Warning 1: Value 570778610.0774231 of field sed_retent of
    feature 6 not successfully written. Possibly due to too larger number with
    respect to field width

    That is a bug that we'll patch, but what it's saying is that the number will be truncated when written to the output shapefile.  I think by default the field width is something like 16 digits, but since this number has a very large decimal, we're getting a value larger than that.  The effect will be that the number is truncated on the decimal.  It doesn't otherwise affect the significant digits of the result.

    Next error is this one:

    natcap.invest.sdr    WARNING  Can't remove temporary file:
    C:\Users\Sandamali/Documents/sedimentation_workspace\aligned_drainage.tif

    This is a warning you can safely ignore that we patched in InVEST 3.3.3; so I'm guessing you're using an older version. But I do recommend upgrading to 3.3.3 because of a critical error we fixed in the LS factor calculation from 3.3.2.

    Last error is this:

    natcap.invest.iui.executor._log_exit_status WARNING  an exception encountered when
    _log_exit_status [Errno socket error] [Errno 11001] getaddrinfo failed

    This happens if InVEST encounters an error and is unable to connect to the Internet.  It can be safely ignored.


  • RichRich Administrator, NatCap Staff
    Hi @dianasandamali91,

    After some debugging, I'm unable to recreate the fieldwidth error on the test data I have for SDR.  Would you be able to send me your latest datastack via Google Drive?  And fine if not since it won't otherwise affect your results in any significant way.
  • Thank you very much.How can i upload files to google drive,any gmail address .
  • I mailed my input file via google drive to admin of  natuaral capital forum.
  • Can i help me to resolve previous problem as i am doing research on using SDR model .Thanks for the all guidance from beginning to carry out my reserch. 
  • RichRich Administrator, NatCap Staff
    Hi @dianasandamali91, I saw your data, but it's missing the watershed shapefile.  Can you send the watershed along too and gmail drive it to richpsharp@gmail.com?
  • K.K thank you very much .I ll send you.
  • edited February 2017
    the input data for  r factor and k factor i submited are annual data set.but your guide i saw now that data should entered per hr.You think that is the problem i get the larger values.I mailed you my sub watershed and watershed shapefiles.thank you very much for guiding me.
    Post edited by dianasandamali91 on
  • I already sent you my all files for you.Can you help me to resolve this problem..
  • RichRich Administrator, NatCap Staff
    Hi, sorry about this, but I see you sent along a 'water.shp' but ESRI shapefiles consist of several files that end in .shp, .dbf, .prj, .sbn, .sbx, .shx, and sometimes others.  
    Can you include all the files that start with 'water'?
  • k.k thanks i ll sent you...
  • RichRich Administrator, NatCap Staff
    Thanks Diana, got your shapefiles this time.  Like I mentioned earlier, the warnings for number truncation are not a problem, and normally I'd suggest you take the results as-are.  But I notice your K factor seems to be off by at least a factor of 1000 making for some very large USLE and later sediment export values.

    Just thought it might be worth pointing out the units on that are ton⋅ha⋅hr/(ha⋅MJ⋅mm).

    Otherwise if you know what you're doing, you can safely ignore those warnings you see in the output log.
  • Thanks for your advices.I convert my k factor values to the units you mentioned earlier.but the values are too large that i have expected.I used SRTM dem file do you think the accuracy of the dem can affect to these larger values? Thanks lot for guiding me.

  • RichRich Administrator, NatCap Staff
    I wouldn't expect the accuracy of the DEM to tweak to large export values for any particular reason.  I suspect the issue might be something else, maybe even model calibration?  I'll have to defer to Perrine for the next time she does a round on the forum.
Sign In or Register to comment.